Bezier Curves in Key Editor not working on imported tracks from older files

I was so pleased to see the introduction of Bezier curves into the key editor in Cubase 11. Fantastic new feature.

However, the curves do not seem to work for me when I import a MIDI track from an older Cubase file.

So, if I create a new track and put some curves on a MIDI CC lane, then do a “Merge MIDI in Loop” command, I can see the interpolated points on the curve, just as expected and just as described in the manual.

However, if I import a track from one of my templates created prior to Cubase 11, and do the exact same thing, the curves are ignored and I see steps instead.

I have not been able to find any difference in the settings for the new and imported tracks in the Inspector. I tried stripping the MIDI Inserts, Modifiers, and Sends from the imported track, but that did not seem to change anything.

Does anyone know if there is anything that can be done about this? Do I need to recreate all of the MIDI tracks in my templates from scratch? (I hope not … )

Thank you,
Chris Trimble

You say import a track…

Have you opened one of those templates and then saved, and then imported tracks from it?

A repro would be nice see How to format a bug report

Yes, I have made changes and re-saved the templates that I am importing tracks from, since upgrading to Cubase 11.

Can you zip and post one of these misbehaving cprs?

Yes. The plot thickened a bit when I went just now to create a simple file to post. One imported track worked fine, a second one did not.

So, what’s different about the 2nd imported track? Is there a setting that needs to be changed?

The attached file should make what I’ve done very clear. bezier (16.8 KB)

Sorry, I don’t understand what you sent. I asked to see the template file. Not a file you imported to.

bezier test (15.8 KB) Hi Steve,

Sorry about the delay, I ran out of time yesterday.

This morning I’ve continued to troubleshoot and experiment.

It turns out that the problem does NOT seem to be related to importing tracks from files created on older versions of Cubase. Instead, it seems to have to do with the Channel selection.

Bezier curves on MIDI CC lanes are working fine for me EXCEPT when the Channel selection on the track is ANY.

I was able to demonstrate the problem starting with a new file and creating simple MIDI tracks set to either ANY or Channel 1. On 1 it works fine, on ANY it does not.

I’ve attached the file. The first track is a MIDI track with Channel set to Any. The only data on the track is a few points on CC1 connected by bezier curves. The second track is an exact replica except that the Channel set to 1.

The next two tracks show the output from these two tracks (created using the Merge MIDI function.) The first one shows steps not curves, the second one shows what you’d expect … additional data has been created that follows the curves.

If you are still interested, can you please try to replicate?

I haven’t found anything in the manual about this. Nonetheless, I’m wondering if maybe this is intentional. Maybe it’s a feature, not a bug, though I can’t imagine the rationale.

Thank you for engaging on this topic.

Chris Trimble

If you don’t mind, please see How to format a bug report

I have a feeling you are looking at points set to Step, as opposed to Ramp.

I may be overlooking something simple, but it’s not that.

I could not reproduce.

Hi again @ctrimble99.

As I said, the difference is caused by the Step/Ramp setting on the CC points. You can see the difference if you have a look at the CC lane in track 4 of the cpr you uploaded.

  • If you hover your mouse cursor over the line between the first and second point in the cc lane there, you will see the little Bezier curve handle.
  • if you select the first cc point in that same lane, you can observe in the info line that it is set to Step.

In order to reproduce or troubleshoot I, or anyone who wishes to help, needs to reproduce all the steps that lead to the bug. You have indicated that the problem stems from importing from a cpr file, so either the file or a step by step reproduction sequence like the example at How to format a bug report would be ideal.

Steve, Thanks for trying to help. What you observe is interesting, but off point. I didn’t create that 4th track, Cubase did, through the MIDI Merge function.

I’m not sure you are understanding that the MIDI Merge is a way to show the MIDI that is output from a track.

So, the question is, why is the output a step when the input is a curve? And why are the results different depending on whether the channel is set to 1 or set to Any?

Also, the file I posted demonstrates the problem exists without importing the track from an old file. My initial hunch that the problem was created by importing a track from an old (pre Cubase 11) file was incorrect.

I created a new post to report the bug earlier today, following the instructions you pointed me to. Thank you for that.