BFD3 Output to Audio Routing

Hi, I am looking for a way to root a subtrack from the BFD3 VSTi to an audio track. What I mean here is to take sat the output for “ BFD Kick In” which I have routed to BFD Mono 1 output to an audio track. BFD appears in the project window as an instrument track like a folder, the top of this folder is the instrument and has all the usual control you would associate with a track, but all the sub folders do not, i.e. you cannot assign individual routings from there.

The only way I have found to achieve this is to create a new VST output (lets call it VST Out 1) , then in the mixer window, in the routing section, assign the instrument sub track (e.g. BDF Kick In\BFD Mono1) to that newly created “VST Out 1”. I then create a new audio track and assign “VST Out 1” as the input. This works but is there a simpler less laborious way of doing it? From videos of Pro Tools it looks like you can directly assign the outputs of a VSTi (AAX) instrument to the input for an audio track. Is there a Cubase equivalent?

I am trying to have my BFD output effectively treated as standard audio tracks that I can process AND have the freedom to move around in the mixer window without necessarily bouncing down to audio.

Any help and pointers much appreciated!

It’s a bit odd, but once you’ve done it you’ll see it’s very easy.

With BFD3 loaded look at the Inspector on the left.

Where it tells you what MIDI inputs you are using, underneath is the name BFD3. Immediately to the right of that is an arrow in a box. If you hover over it it tells you its the ‘Activate Outputs’ icon.

Click on it and a drop-down with all the BFD outputs on it appears. Just click on the circles to make them solid and the output will appear in Cubase. Then save this as a template or default project so you don’t have to do it again.

Thanks for this.

I had actually got this far and was looking to go a step further. When you activate these outputs they appears as sub tracks to the BFD instrument. They are limited in that you cant move them around to other places in the mix (e.g. if I want to have the kick outputs alongside other audio drums I have recorded), so was looking for a way to route these outputs to standard audio tracks. I found a way to do it by creating additional VST outputs and in the mixer linking the BFD output to these , then using the VST outputs as inputs to audio tracks, but I get tired just typing that…

I’ve saved eveything as presets and templates now so should be straightforward in the future, but was wondering if I had overlooked an easier way (and if not, directly mapping VST outputs to audio track inputs would be a great addition in the future - Pro Tools appears to do this)

If you use “Rack Instrument” instead of “Track Instrument” you can move all the xtra output where you want in the Cubase project window

ah, ill take a look at this thanks.

To route the kit pieces to their own audio tracks in Cubase you need to use the BFD 3 mixer. Select a track in the BFD mixer and then click at the bottom that is where one can choose what actual track to route a kit piece to. The default is everything goes through the master out and that is a single audio track… As above be sure you have activated all audio outs.

Normally, I’d launch BFD3, after adding the kit I want I’d choose from the top right drop down “Activate Outputs” > activate all outputs.
In cubase pro 10 I’d see in my mixer window the new channels, with names like BFDs02, BFDs03… and so on.
I’d return to BFD3 and at the bottom of each drum in the mixer I’d click on Master and change the output to the whatever channel I want.

That doesn’t work now for some reason.

Everything keeps going though the AmbMix on BFD3, and I can not get it to change.

Any thoughts?

The new BFD3 updates made it so you have to first left click to highlight each channel in the BFD mixer before you can assign the audio output to it, otherwise any changes you make will only affect the highlighted track.

OK, I found that if I control click on the mixer track of the instrument itself inside the BFD3 mixer, I got a pop up that has a lot of options. I choose “auto assign outputs” and you’re good.

Ok, well, I’m back with this same dumb problem.

I have 2 cymbals that are assigned to Aux3, I want them each on their own mono channel.
No matter what I do, I can not get them to re-route to their own mono channel.

I’ve also noticed the 2 cymbals are the only instrument (drums) without a color line on the top. Every other drum and cymbal has a blue line above it, but the 2 cymbals in question have no color line on top.


Are these core library cymbals or from an expansion pack? Which cymbals are they? I might take a look.

This works pretty well:

Auto-Assign outputs (WYSIWYG)

Standing for ‘What You See Is What You Get’, this function sequentially assigns the output of each direct channel to a mono output, and any Bus, Aux or Ambient mic channel to a stereo output.

Also, make sure you hit the triangle to expand any busses so you can see what got assigned.