Big problems with Dorico 3

I’m sad to say I’ve been experiencing a lot of issues since upgrading to Dorico Pro 3. I’m hoping someone can help me out.

The application has a hard time starting up about half the time- I get these error messages:
eLicenser Control-Error “Application ‘Dorico Pro 3/Elements 3/LE3’ has caused the following error: Failed to send GetInfo command”

If it does load up, it usually freezes within the half hour and I have to restart.

Also, I don’t know if this is related but it’s just as detrimental. I’ve failed to get any playback- the playhead won’t move and the process usually freezes the application. This is using NotePerformer 3 as well as the sounds bundled with Dorico. This is with new projects as well as with existing ones that used to play back with Dorico 2.
One thing I’ve noticed is that I can get the NotePerformer mixer to show in the older projects but not in new ones.

I’m on Mac OS 10.13.6, Dorico 3.0.10 and NotePerformer 3.3.0

Any help would be greatly appreciated.

For a start, would you please start Dorico, then create a new project from piano template and add some arbitrary notes. Does playback work then?
In any case, please then choose from the main menu ‘Help > Create Diagnostic Report’. That creates a zip file on your desktop, please attach here.

Regarding the eLicenser issue, do you have the Dorico license on a USB dongle? If so, try on a different USB port.
Also, do you have the very latest eLC software running? You can get the latest from here:
There is no guarantee that it will work better, but there is a chance.

Having a similar problem. Start a new project, add a player, save, no problem. Add another player, save, and get the same message that MMoston is getting. Minus the ‘Elements 3’ part. Tried starting a new project with the same results. e-licenser is showing product is registered as is Steinberg’s site. I can’t open Dorico 2 at all. Cubase 10.5 is working fine.

Try following: Start Activity Monitor and have a look for a process called Synsopos. Is there one even though Dorico or Cubase is not running? If so, kill the process and try again to start Dorico.
Btw, the Synsopos process is responsible for the copy protection and is a necessary background task in order for Steinberg products to run .

Synsopos was not running without Dorico. It shows as soon as I start Dorico, or Cubase. Still having the same problem with Dorico.

If I run Cubase at the same time as Dorico, Dorico works. If I close Cubase, same old problem with Dorico. Guess the kid won’t do anything without his mommy.

Thanks for your reply, Ulf.

I went through all the steps you recommended- downloaded lates eLicenser software, plugged dongle into a different port, started Dorico- got the same error messages. Also one that said “Application ‘VST Audio Engine 2.0’ has caused the following error: Application not registered” That is a newish message for me. Started a new project with solo piano and added some notes. Still no playback- the playback head doesn’t move.
I’ve attached a diagnostics report from that instance.

I also tried the Synsopos test- it went away when I quit Dorico and came back when I restarted it.

Thanks in advance for your help with this!
Dorico (472 KB)

Cubase is not the mommy, it’s the Synsopos. But as a different workaround you could try starting the eLicenser Control Center, since that one also starts the Synsopos process.
Also, I think, in your case definitely an upgrade to the latest eLC software would solve the problem, because that what you describe sounds familiar, and that issue got fixed already.
So please go to and get the latest eLC.

This is most curious. You said that you have problems with Dorico 3, but the error message says something about audio engine 2.0.
Dorico 3 comes with audio engine 3, so I wonder where that message comes from.
Are you mixing Dorico 2 and 3 or have fiddled around with the installation?

Please check in Activity Monitor:

  • Make sure before launching Dorico 3 there is no VSTAudioEngine3 process
  • Then launch Dorico 3 and see what VSTAudioEngine process gets launched, is it 2 or 3?

According to the diagnostics, I see no reason why playback should not work, I really wonder.
In regards to this please try the following:
Load again that piano test project, then go to Edit > Device Setup and change the sample rate to a different value, wait a few seconds and then set it back to the old value.
Wait a little again and close the dialog. Then try playing back again, does it then do?

Also, you are using the NotePerformer template. Please do a further check for me.
Go to Play Mode and choose Play > Playback Template, but this time choose the HSSE template.
Then open the HALion Sonic SE editor window and click with the mouse on the on-screen keyboard.
Does sound come out? That would prove that the audio engine as such is running and able to produce audio.

Furthermore, your diagnostic report contains two crash reports of the audio engine.
The crashes are basically at the same location and actually during shutting down of the process.
Did the operating system notify you about the crashes with an alert box?

Thanks again for your reply, Ulf.

The playback issues got resolved- while doing your Device Setup suggestion, I realized that I hadn’t chosen my audio interface and it was set to built-in audio. My bad. Once I chose my interface, the playback worked just fine and the NotePerformer mixer was back. Thank you for that.

I don’t know what to tell you about audio engine 2.0. I haven’t been mixing Dorico 2 and 3 that I know of. Maybe I need to do a reinstallation?

Activity Monitor didn’t specify which VSTAudioEngine got launched when I reopened Dorico. I’m attaching a screen shot so that you could see- maybe you can tell.

Yes, I believe I got the notifications of the crash.

SO, the playback issue has been resolved. But the error messages still come up upon launching and I’m about to start my arranging day and see whether the program keeps freezing. I assume it will.

Right, I forgot that on Mac we don’t have the major version number in the process name (on Windows we have).

Anyway, the playback issue is resolved. Please continue using Dorico and report back any further issues.

My problem still exists. I also have seen the error box referencing VST audio engine 2.0. I tried running Dorico with e-lincenser open and it didn’t solve the issue.

So you have upgraded to the newest eLC, right? And you do have both Dorico 2 and 3 installed, and 2 does not run at all, and 3 only when Cubase is running, correct?
But if Dorico 3 is actually up and running then it behaves correctly, also right?
And you checked the Activity Monitor, there is no zombied VSTAudioEngine process lingering on somewhere?

I agree that Dorico 3 is extremely buggy. When you click Help->Check for Updates it takes you to a page for Dorico 2 downloads. Entering notes won’t produce any sound unless you first initiate a playback. It’s impossible to transpose down an augmented unison. And the list goes on. I hope a bug fix release comes out soon.

To say the least, on that bug I’m currently working on…

So far, a day of writing and no freezes. (I upgraded to the lates Dorico version last night so maybe that helped.) Just the issues on start-up.

Have upgrade the eLC

Only works if Cubase is also running.

I think Dorico 3 is running correctly if Cubase is also running. Buy I haven’t done anything but add a few players.

When Dorico loads, a VSTAudioEngine process shows up in Activity Monitor. No zombie.

And how about the other workaround, i.e. first launch the eLicenser Control Center and then Dorico?
Because the eLicenser Control Center also launches the required Synsopos process.
Normally, also Dorico itself should trigger a launch of that Synsopos, but in your case that does not work,
and therefore the license check can’t be executed and Dorico exits or does not work stable.

Do you have the Dorico license also on the USB eLicenser?
We have a bunch of customers that reported problems with the USB eLicenser, our eLicenser guys are working on it now.
But your case is different somehow, because Cubase launches always (when I understood correctly)
so it can’t be a communication problem to the USB dongle then.

It must be an installation or access right issue, because Dorico just can’t launch that Synsopos process.

Cubase, as far as I can tell, is working perfectly. However today, Dorico is not working when Cubase is open. (Probably spoke too soon yesterday.) When I try to open Dorico 2, I get:

It’s been a couple of months since I used Dorico 2, so I don’t know if this problem started with the install of 3 or not.

I deleted both 2 and 3 and reinstalled 3. Didn’t help. Launching the eLicenser Control Center first doesn’t help. Dorico launches, I can save a project once, but then I get the error messages if I try to save again. Among one of errors I’m getting is that HALion Sonic SE 3 is not registered. I can load Halion Sonic SE on the play tab but there are no instruments listed. I have downloaded the Dorico sounds.

Could you please do Help > Create Diagnostic Report ? That creates a zip file on your desktop, please attach it here.

Dorico (1.12 MB)