Black Box HG-2

I am wondering what the VST difference is on older Cubase DAW’s (4 and 5) that all use VST 2.4 and VST 3 in comparison to newer versions of Cubase. Is there any reason the Black Box HG-2 VST will not work on older Cubase 4 and 5 systems ? I have tried it with Cubase 4 and 5 (both 32 and 64 bit) and though it installs in the right folders Cubase does not list it as available even after re-scanning for plug-ins. Both Cubase 4 and 5 use VST 2.4 as well as VST 3 . Black Box says it is compatible with VST 2.4 as well as VST 3. I am running on windows 7 ultimate. Also, other new VST’s work fine like Waldorf PPG 3 , ME-80, Wider, etc.
Thanks

In case anyone cares… Simply putting in this windows update : vc_redist.x86.exe - which is a Microsoft Visual C++ 2015 Redistributable (x86) file solved the windows 7 vst issues for multiple VST effects and instruments.