Black Square on some vst's

After using Edit instrument mode some of my VST’s leave behind a Black square after closing the instrument. I wanted to illustrate this by take a photo with Mac’s Grab app. The strange thing is when I clicked on that app to open it the black square disappeared. Has anyone got the same problem?

Hi,

Make a screenshot via Mac OS system function, please. Press Alt + Shift + 3. The screenshot is stored on your desktop.

It sounds like a re-draw issue. Does it disappear when you minimase - maximise the Project window (where the black square is, as I guess)?

Ah sorry I forgot the point I was trying to make was when I click on Grab app which is in my app dock the black box disappears so i cant take a photo of it! Very strange :slight_smile: However Ive taken to photos with my smartphone showing what happens when I click on top left hand button of the VST as shown
Blackbox.jpg
Vst.jpg

This is 32-bit plug-in in 64-bit Cubase. The plug-in is bridged. Does the plug-in have a 64-bit version?

Hello,

this looks like the issue described here: https://www.steinberg.net/forums/viewtopic.php?f=233&t=77989#p450866

Many thanks for the link Fabio but according to your response

The plug-ins I have (like many other users) are not VST3 or 64bit. In fact if I go into 64 bit mode the plugin is not recognised at all! This really should be fixed

Ive been experimenting with this problem and found that if I go to the dock and click on say iTunes or calendar-as soon as one of these programmes open the black box disappears-anyone else tried this?

I checked the website and seems like there is no Mac VST 64-bit version of that plug-in, that’s unfortunate.

From what I gather from the issues entered in our system, this cannot be fixed in the 32-bit version due to technical limitations (Cocoa <-> Carbon window overlay). However, all plug-ins should be provided in 64-bit form nowadays, please note that Cubase 8.5 will be the last version offering the software in 32-bit architecture.
I’m not totally sure if jBridgeM can be useful in this instance, but perhaps worth a try if you rely on that plug-in.

[EDIT: yes, switching the focus to another software’s window, the black frame disappears]

Hi Fabio Ive tried the jbridgeM and it did the trick! Thank you! :slight_smile: