Blues Essentials For Groove Agent 4

Hi Guys,

Just a quick question. I have Cubase LE AI 9.5 and want to add the Blues Essentials addon for groove agent 4, will this run ok on this version of Cubase.

Cheers

This expansion requires the “Acoustic Agent” kit for Groove Agent SE 4, which is exclusive to Cubase Elements or higher.

You can upgrade to Cubase Elements here:
https://www.steinberg.net/en/shop/buy_product/product/cubase-elements-95.html

If you’re not sure which version you have:

If you got your Cubase for free with an audio interface or keyboard, then you have either Cubase AI or Cubase LE. Pick “Upgrade from Cubase LE, AI, Essential or Sequel”.

If you bought Cubase from Steinberg or another store, then you already have Cubase Elements. You can verify this by trying to load a preset called “Break Me Down”.

Thanks for the info. Looks like I’ll be upgrading.