Bluetooth headphones don't work

A couple of problems

  1. It’s not possible to see which device I am selecting in the edit>device dialog. See attachment. The image shows both the edit>device dialog (on the left) and audio MIDI setup audio window (on the right). The bluetooth headphones I am using has both an input (microphone) and output device (stereo earbuds). The edit>device dialog does not distinguish between the input device and the output device in the device labels.

  2. No sound no matter which one I select.

  3. Can’t get back to sound using built in outputs either without re-launching Dorico with bluetooth disabled. Not surprising given the above.
    edit device.png

Hm, so I’m not the only one. I thought I was doing something wrong, but maybe it’s not my fault then… (using Sennheiser Momentum M2 AEBT Bluetooth headphones)

I tried with my Parrot 2.0 bluetooth headphones and same result here. Had to restart to get some sound back.

hmmm… starting to put 2 plus 2 together. It seems from the evidence here and elsewhere that Steinberg apps are not core audio compliant. This would be quite unbelievable to me if true. So Daniel, I am asking you for an official statement whether Dorico as well as other Steinberg apps are indeed not core audio compliant.

Well, I wouldn’t guarantee that we are core audio compliant, but definitely that we strive to be compliant. Especially, we have never heard of any case so far that we are not. Our main product Cubase is out in the market since years and used on thousands of computers, also on Mac. Having just said that, we already had some cases, where, porting the Cubase audio engine to Dorico, led to some unexpected behaviour. So could be, that this is another case.

Could you please create a simple Piano project with your bluetooth driver selected and post it here. I will then have a look and see what might be wrong. Thanks.

Ulf, on the topic of porting the Cubase engine, when you run into issues that need fixing then does that get fed back to Cubase? I’m imagining how great a single codebase for both applications would be.

Ulf, here are 3 different files of the same song. The one without a number in the filename plays back through the normal built-in audio device. This works as expected. The file with 1 on the end of the filename uses the first of the two possible bluetooth devices. The file with 2 uses the second of the two. Note that in the latter two, there was no way to set the sample rate. I assume this is part of the problem.

Thanks for looking into this.
train theme.zip (650 KB)

Actually yes, and even in both ways. Fixes in the Cubase engine get fed back into Dorico’s engine as well as the other way round. So from the audio processing part they indeed share the same codebase.

Thanks for the data.
Now, the port mapping for the first project looks exactly as expected for built-in audio. The audio engine’s output is routed to the built-in output ports.
The mapping of the second project looks exactly same to that of the first one. The built-in audio outputs are listed and the engine’s output mapped to those ones. So I would expect audio to still come out via built-in audio.
The third one is different though. Here only “Dave’s AirPods 1” is listed as input port, but there is no output port. Though the engine also detects input ports, they are in fact irrelevant, and only output ports matter. But since no output ports do get detected, there is also no mapping information and so the engine sends the audio into void, hence nothing to hear.

So “westworld train theme1” is most suspicious, because you say that Dave’s AirPods was selected as driver, but from the mapping data it looks completely different. Could you please check again and maybe upload again.

The second suspicious thing is the string “Dave’s AirPods 1”. The apostrophe somehow seems to got mangled. Could be that this is a problem (if actually an output port gets detected.) We once had a similar problem on Win with device names that used characters outside the ASCII range. Well, the apostrophe is still in range, but looks mangled here, so we probably have to have a look at it, when we return to the office after new year.

Here’s another try at the version 1 of the file. I also changed the name of the AirPods to remove the apostrophe. Still no sound and when opening the file, the edit>device does not allow setting the sample rate.
westworld train theme 1.dorico.zip (216 KB)

And FYI, every other audio app can automatically detect and connect to my AirPods or they connect by selecting in preferences. Once selected the first time, they automatically connected the next launch. All of these apps predate the release of the AirPods (since they were released just last week). None of them had an issue with the name when it included an apostrophe.

The other apps I tested are:

Sibelius 7.1.3
Logic Pro X 10.2.4
Transcribe 8.64.0
Vienna Instruments Pro Standalone 2.4.15551
Pianoteq Standalone 5.7.1
iTunes 12.5.4.42

Those high byte characters look like a UTF8 encoding problem, which may suggest the bug (and also a workaround). Try renaming the headphones to something without an apostrophe.

PS Ulf: what are you doing here at this hour? Happy Christmas! :slight_smile:

Yeah, I did that already, see my previous post. Still doesn’t work. So it’s not the apostrophe.

I’m helping Santa Claus, and you? :wink: Merry Christmas

Thanks again for the upload. This time it looks sligtly different, but still not right.

Again, only the input port “AirPods 1” gets recognized, but no output ports.
Could it be that the outputs are still claimed by some other application? Sorry, just guessing.

We have to have a closer look at it when we are back in the office next year. I would have liked to help quicker, but sorry, please be a little patient.

I don’t understand this question. This is a macOS machine. Multiple apps can be open and “claim” any audio output device. The active window owns that device at any given time.

I created the file I sent you using Sibelius and Transcribe open at the same time and then imported that to Dorico. The active app (by selection) is the one that outputs sound. There should be no conflict here. I assume Dorico can do the same.

So I also tried working around this issue using Rogue Amoeba’s Loopback app to isolate the AirPods from Doric. Dorico can see this audio device, but there is still no sound when trying to use it. I am certain I have it set up correctly as I can route other apps through this device and they all work fine. So there is some OS compatibility problem with Dorico. I hope this is just a temporary Dorico issue and not a Steinberg audio engine problem. I would try to see if this works using Cubase, but I don’t have that app and there are no trials anymore.

Maybe someone in this forum has Cubase 9 for macOS and can see if you can get bluetooth phones to work and/or see if Cubase and Loopback can work together or not.

Anyway, don’t worry about this until you get back. Enjoy your holiday.

Thanks for your understanding. I can also get you a Cubase trial license when I’m back in the office.
Please bear with us and I’m sure we will get this sorted sooner or later.

Cheers,
Ulf

Ulf, awesome to see your dedication! Enjoy your break.

Progress…

I was able to get my Airpods working. Setup as follows (see attached image):

  1. Using Rogue Amoeba Loopback - make sure Monitor audio through: AirPods is enabled
  2. In Audio MIDI Setup: create a multi-Output device with AirPods and Loopback enabled.
  3. In sound preferences, select AirPods as the Output device
  4. In Dorico Eidt>Device select the Multi-Output device that was created in Audio MIDI Setup
  5. You might need to delete and reinstantiate the VSTaudio engine file in Dorico

Not sure yet how reliable this is, but it does seem to keep the connection across Launches. So I’m encouraged.

Also, this is just a workaround since it requires an additional program that shouldn’t really be needed.
airpods setup.jpg

Turns out you don’t need Loopback after all.

Just create a multi-output aggregate device in audio MIDI setup and select the AirPods as the output device in System preferences. See attached.

I think what is going on here is one or both of the following:

  1. The aggregate device is forcing the sample rate since it is combined with the built in device which is a well supported device. This wasn’t happening when trying to connect to the AirPods directly.
  2. The output part of the AirPods are associated with the aggregate device, so there is no confusion which device to select in Dorico. Dorico provides two AirPods devices in the edit dialog and it’s not possible to determine which is which from the dialog.

Just a guess. But this seems to work.
airpod setup.jpg