Bluetooth headphones don't work

Thanks again for the upload. This time it looks sligtly different, but still not right.

Again, only the input port “AirPods 1” gets recognized, but no output ports.
Could it be that the outputs are still claimed by some other application? Sorry, just guessing.

We have to have a closer look at it when we are back in the office next year. I would have liked to help quicker, but sorry, please be a little patient.

I don’t understand this question. This is a macOS machine. Multiple apps can be open and “claim” any audio output device. The active window owns that device at any given time.

I created the file I sent you using Sibelius and Transcribe open at the same time and then imported that to Dorico. The active app (by selection) is the one that outputs sound. There should be no conflict here. I assume Dorico can do the same.

So I also tried working around this issue using Rogue Amoeba’s Loopback app to isolate the AirPods from Doric. Dorico can see this audio device, but there is still no sound when trying to use it. I am certain I have it set up correctly as I can route other apps through this device and they all work fine. So there is some OS compatibility problem with Dorico. I hope this is just a temporary Dorico issue and not a Steinberg audio engine problem. I would try to see if this works using Cubase, but I don’t have that app and there are no trials anymore.

Maybe someone in this forum has Cubase 9 for macOS and can see if you can get bluetooth phones to work and/or see if Cubase and Loopback can work together or not.

Anyway, don’t worry about this until you get back. Enjoy your holiday.

Thanks for your understanding. I can also get you a Cubase trial license when I’m back in the office.
Please bear with us and I’m sure we will get this sorted sooner or later.


Ulf, awesome to see your dedication! Enjoy your break.


I was able to get my Airpods working. Setup as follows (see attached image):

  1. Using Rogue Amoeba Loopback - make sure Monitor audio through: AirPods is enabled
  2. In Audio MIDI Setup: create a multi-Output device with AirPods and Loopback enabled.
  3. In sound preferences, select AirPods as the Output device
  4. In Dorico Eidt>Device select the Multi-Output device that was created in Audio MIDI Setup
  5. You might need to delete and reinstantiate the VSTaudio engine file in Dorico

Not sure yet how reliable this is, but it does seem to keep the connection across Launches. So I’m encouraged.

Also, this is just a workaround since it requires an additional program that shouldn’t really be needed.
airpods setup.jpg

Turns out you don’t need Loopback after all.

Just create a multi-output aggregate device in audio MIDI setup and select the AirPods as the output device in System preferences. See attached.

I think what is going on here is one or both of the following:

  1. The aggregate device is forcing the sample rate since it is combined with the built in device which is a well supported device. This wasn’t happening when trying to connect to the AirPods directly.
  2. The output part of the AirPods are associated with the aggregate device, so there is no confusion which device to select in Dorico. Dorico provides two AirPods devices in the edit dialog and it’s not possible to determine which is which from the dialog.

Just a guess. But this seems to work.
airpod setup.jpg

So I downloaded a trial of Nuendo 7.1.20. This has the same issue with AirPods. Same workaround works with Nuendo.

I would have almost guessed that it is a general problem across Cubase, Nuendo and Dorico, since they share the same audio engine. We will have a further look into this and fix it properly for all of them.
Good that you found a workaround for yourself.

Hi everyone,

I ordered a pair of BlueTooth headphones (JBL T450BT) in order to investigate into this and found out the following:

The issue is not about BlueTooth or core audio compliance, it’s much more trivial. Also my JBL is not only a headphone but also has a microphone. So in the system’s list of audio devices, two devices turn up, one for the input, one for the output. That’s all fine, but what the problem is, both devices have exactly the same name.

So Dorico (and same for Cubase / Nuendo) reads from the system the list of devices and presents the list to the user. The user makes his choice and Dorico tries to set the device with the given name. But even if you choose the second of the equally named devices, due to the name match always the first device will get chosen.

Odd though that the first device is usually the input device. Dorico has no use for such a device and accordingly will stay silent. With Cubase or Nuendo you would still be able to record audio through such a device but also won’t hear anything, thus can’t monitor the incoming signal; also useless.

Again, this whole issue is not related to BlueTooth. I could also create 2 identically named aggregated devices, that use conventional i/o. Same problem, respectively, if the device with the output is listed first, sound comes out.

So the best way to get around all this is - as already described by dbudde - create an aggregated device with a unique name. Though it is “aggregated”, just choose the output device of your headphone (or whatever) to participate in this device. Then restart Dorico and under Device Setup select and use it. This is all safe.

Of course, it’s just a workaround. We will work on this so that Dorico (and Cubase / Nuendo) can deal properly with such situation.

One more addition, depending on the hardware you are using, but the microphone of my JBL headphone only has a sampling rate of 8kHz.
Dorico, Cubase and Nuendo don’t support 8kHz, so don’t aggregate such input device with an output that has more capabilities, because then only ever 8kHz will be chosen and then again, you won’t get any sound out.

Thanks Ulf, I was having this exact issue. I was wondering why there were two devices with exactly the same name…
Looking forward to the patch. :smiley:

Hi everyone.

I’ve tried to follow the conversation above, but I’m not on a Mac, so the screen shots don’t help, and I have no idea how to create an aggregate…

I’m using Dorico 1.2.10139 on a Surface Pro 3, and for the life of me, I can’t get the playback to come out of the bluetooth speaker. It works on the built in speakers, and I can force it to work on wired headphones, but neither my bluetooth speaker nor headphones will work. In the Device Setup, my only choices are the “Generic Low Latency ASIO Driver”, or the “Yamaha Steinberg USB ASIO”, which causes the whole program to crash. When I open the Device Setup dialogue for the generic driver, it shows “Speakers” in the output and that’s all.

Any help would be greatly appreciated. This is very frustrating.

First of all, this whole thread of bluetooth headsets not working with Dorico is actually only about Mac. On Windows - so far - it was never reported to be a problem. I do have a JBL Bluetooth headset here and it does work well with Dorico on Windows.

The “Yamaha Steinberg USB ASIO” driver won’t work together with the Bluetooth headset, so you have to choose the “Generic Low Latency ASIO Driver”. Attached is a screenshot of how it looks in my case. In the driver panel in the list of Output Ports the JBL device turns up and is selected.

You say in your case the Bluetooth device is not listed. How about the option “Allow ASIO host application to take exclusive control of selected port configuration” at the top of the device panel? If you toggle that option, does something change in the list of output ports?

You could also try a different general purpose ASIO driver, have a look at
Maybe that one will list your headset as output ports.

Hi Ulf. Thanks for all the quick feedback. It was definitely the Allow ASIO host… that fixed it. I was sure I had tried this, but apparently that’s all it took. Thanks again for the great response.

You are more than welcome. And I’m glad that it works now for you.

Hey Ulf/Cubase crew.

I am resurrecting this thread because after hours of attempting to solve this issue, the multi-output device workaround has sound coming out of my headphones in Cubase for the first time on the 2018 Macbook Pro, but for a totally different issue.

I’m using Cubase in OSX with Bose NON-bluetooth headphones as I fly a lot. When using the computer outside of Cubase, sound is easily played through either headphones or computer, automatically switching when i unplug the headphones. With Cubase, upon plugging ANY headphones in, the audio does not play through the headphones using “Built In Audio”. Whenever I want to switch between headphones and speakers in cubase it requires manually changing the ASIO driver back and forth between Built in Audio and Multi Output Device.

I’m not sure if this is solely an issue with the 2018 Macbook Pros specifically, but thought you guys would want to know. I’m fine with switching manually but if this issue is consistent across all 2018 Macbooks I assume it will become more prevalent.


What version of Cubase are you running and what is the exact model of your Bose headphone?
If it is really only an ordinary headset without a microphone, then it should work as expected.
On Monday, when I’m back in the office, I can check on my iMac or ask someone with a McBook Pro.

Hi Guys,

I’m having the same issue. My bluetooth headphones (Sony WH-1000XM3) work fine on every application except Dorico, on which the sound is transferred to my speakers instead. The speakers are in fact also a mic, which I believe is causing the problem. I have read making an aggregate device solves the problem. How does one do this on Windows 10?

Thanks for any and all help!

That with the aggregate device is Mac only. On Win, choose in Device Setup the Generic Low Latency Driver and open the Device Control Panel. In the little window that opens then, have a look in the middle for the list of output ports. In that list you should find your Sony headset. Click on the little checkbox in front of the name to make it the output.

Thanks for the suggestion Ulf, I see a problem.
My headphones are not showing up as an output even though they are definitely well conected.
Please see images in attachment.