Bome: add track preset macro

I’m testing Bome MIDI Translator Pro and try to automate the adding of a specific track preset by sending key strokes to Cubase. So basicly to get this done it must be possible to do it all with key commands. I managed to open the track preset window, tab to the search field and insert a search string which finds my track preset as the only result.

But from then on it seems impossible to get focus on the preset itself and select it (area beneath it). It seems the only way is selecting it with your mouse.

Somebody a suggestion of a key stroke which moves focus from the track preset search field to the actual preset to select it?

Or an alternative procedure to insert a track preset by name without using a mouse (project logical editor/macro)?

Cheers

Hi,

Press Tab, you will jump from the Search field to the Results area.

Arg… and to be complete: one arrow down and it’s highlighted…

/shame

Thanks a lot!

I’ve been trying (and then given up) to do the same thing with Metagrid. I’ll give this a try.

Thanks Martin

This is so close to working, but…

If you watch the attached gif you can can see that Martin’s suggestion works great. After the preset name is entered in the search field, TAB and DOWN successfully selects the desired preset. But then a small window briefly pops up on the left side. When that pop-up closes the focus has changed from the Track Preset Window to the Project Window & I can’t add the Track then because the focus is wrong.

While the gif is of a series of Metagrid Macros (split up so they are slow enough to watch), the same thing happens when doing it by hand using only the mouse & keyboard. By hand it doesn’t matter because you can click the “Add Track” button even when that window doesn’t have focus. For macros the focus needs to be correct for things to work.

Hi,

Sorry, I can’t stop the gif. What kind of window is it? What’s written there?

You can put in alt+tab to jump focus back or take off the previewer. I ofthen just navigate this with the keyboard. I have never run in to your issue. I dont use kontakt. You should check the kontakt setup/settings, if you can hide that load box. If you dont need the preview, that will be a safe bet, as nothing loads before execute. Changing track preset might be a different story with the previewer.

Yes, I guess something is loaded and this is the loading dialog.

FWIW: I managed to load a track preset based on its name. It seems to need 100ms pause between key commands. Waiting for the pre-listen (last step ‘Enter’) needs a 2 second pause.

It’s all fragile. When you change view settings in the track preset window the number of tabs needed changes. Maybe the 2 sec delay isn’t enough when loading heavier plugins. But I give it a try.

But it seems possible to pass input from Bome to Cubase. Gonna look for other possibilities to macro.

Hi,

The preview loading time might be different depending on the exact preset. It’s definitely totally different, if it would be an empty Audio track, or if it would be multitimbral HALion 6 Instrument track with several more plug-ins (REVerence, and other heavy plug-ins) and Channel Strip.

The good thing is that I would build a Bome preset per track preset, so I can have different delays for different track presets :slight_smile:

You can’t turn of the pre-listening in the track preset window, can you?

Unfortunately you can’t.

Just did it:

“app specific command” > Using Track Preset
“keyboard shortcut” > TAB
“text” > name of track preset. For instance “Kontakt Empty”
“keyboard shortcut” ENTER

Spent some time just selecting by mouse but not loading Track Presets for different ‘platforms’. I could visually see a dialog box only for Kontakt and East-West Play. But they behaved differently. Kontakt left the focus on the Project Window while Play returned the focus to the Track Preset dialog box (which seems much better behaved).

I snagged a frame from the earlier gif showing the Kontakt box.
Track preset dialog box.JPG