[BON-11577] AAF import woes on EuCon system

Hey all.
I just tried importing an AAF (folder linked) into N7, which prompted following error:

" ! Failed to read AAF tracks… [Err 8007007E] "

N6.5 does this as well.
It happens with various AAF files. AAF import works fine however on my notebook, which has the same version of N7 and 6.5, the only difference between both systems is that the notebook’s running Win 8.1 and has no EuCon software installed, and the studio system is running Win 7 and HAS EuCon (latest version) installed.
So I suspect EuCon is, somehow the culprit.
Any ideas / solutions?

Hi, could you provide us with one of the AAF files somehow? I’d like to have a look at this.

Sure. I’ll upload one later on, thanks!

@ Ed: See PM. Thanks a lot!

I received the AAF, thanks! Could you let me know which EuCon software version is currently installed?

It’s the current one - can’t look at the version number right now as I’m not in the studio anymore. But it’s definitely the latest version, same for the BlackMagic and UCX drivers…

Okay, I have uploaded the test AAF here internally and filed a bug report.

Hello Heiner,

thanks for the AAF, but I can’t reproduce that issue here or at least not in the way that you’ve described it.
First, the AAF-Filter and EuCon-Adapter have no connection or dependency, so it can’t be that an AAF fails to load because of the EuCon software installed.
And I have tried here with an MC Control (connected and disconnected) and your AAF just imports fine.
Second, I can provoke the error message that you are seeing, but therefore I have to break the AAF-Filter installation.
The AAF-Filter consists of one main and several helper libraries.
Have a look at Program Files/Steinberg/Nuendo{x}/Components/AAF-Filter, you should see the main file aaffilter.dll plus the helper AAFCOAPI.dll and in the subfolder aafext the files AAFINTP.dll and AAFPGAPI.dll. If I delet all the helper dlls (but not aaffitler.dll) then Nuendo will still prompt me for the AAF-file to import, but when I select and confirm, then that error message 8007007E will pop up.
So I suspect that on your studio system the installation of the AAF-Filter is somehow corrupted. Could you please check?


Hi Ulf!
Hello and thanks for your prompt reaction. I appreciate that!
I shall look into that on Tuesday, I won’t be in the studio before then, and see if I can get the dlls re-installed. It’s still strange though, because on 6.5, importing AAFs worked without issue, until I tried to import one for the first time AFTER installing EuCon. Hence my suspicion.
Anyhow I’ll try it out and report. Thanks again. :slight_smile:

SOLVED! :smiley:
As Ulf had suggested via PM, I checked the MSVCR100 and MSVCP100 dlls in the /windows/system32 folder. They had somehow become corrupted. A quick re-install of the Visual C++ redistributable package (available on the Microsoft download site) solved the problem!
Just thought I’d post that here in case some of you run into this.
Thanks a lot Steinberg for latching on to my problem so soon! :slight_smile:
(And in case someone’s wondering - this solution post is so late not because of Steinberg’s response time, but simply because I was on holiday… :sunglasses: )