bounce macro?

hi=)

So I was wondering how to bounce multiple events (without having to render files on disk etc… just a simple bounce)

I have run into some macro deficiencies it seems…


Bounce multiple events macro:

  1. Transport - Locate Next Event
  2. Edit - Select Event
  3. Audio - Bounce Selection
  4. ---------------------------------here i need a “enter” key command ( to confirm the “replace event?” )
  5. ---------------------------------here i need a "repeat step 1-4 until no more events are to the right of the last bounce


    Example: you record 64 bars of audio and split them into 64 parts - one usually does not want to press “bounce and enter” 64 times. :wink:


    Does anybody know how I can bounce multiple separate events?

Thx=)

Why not just use “Render in Place”? That’s an intelligent bounce :slight_smile: You can process all 64 separate parts on one track and have them processed as 64 separate parts. Or you could even do 64 tracks with each one part on it? All in one go.

hey, good thinking, Nickeldome=)

Render in place would be a choice… but…

With render in place it always makes new tracks (unlike bounce which retains the “in-place” part of it)
also
With Render in place - when you select “as separate events” it does not do separate events… - It only does separate events if there is a space between the events… (it does not consider events as separate if there is no space between the cut events… - seems like an oversight or so…)

anywho, thanks for your input=)

I’m still open to how we can bounce multiple events (and keep them separated) via macro…anybody?

I just played with this a little, and at first it was as you described: If I tried to RIP several adjacent audio events (those whose end times were the same as the subsequent event’s start time), they would be rendered as one event. If I subtracted 1 sample from the events’ length, it would render each one separately.

Then later, after I restarted Cubase, it did work. Adjacent events were RIP’d to separate adjacent events.

So there’s more troubleshooting to be done if a report is to be made. One idea– maybe the render settings display isn’t being updated correctly, and then upon restart they do?

hmm… the only way I can get it to do separate events is leaving that minimal space…
(but that minimal space adds up if you take one of those events and duplicate it x times - things are out of place)
-and if i want an exact length i would have to rebounce each rendered event one by one (which not only bounces the removed space but each bounce would have to be on an individual basis - which would negate the whole bulk action…)

Are you sure that you didn’t just render those adjacent events with spaces when you restarted?

-a multi-bounce would come in handy somewhere down the line… (select x events and bounce to individual events)

thanks for your solidarity=)

Of course.

This is what I did. Do this repro after setting RIP to
As Separate Events
Dry or Channel Settings
keep source events unchanged (just how I did it)
Quit. Restart Cubase

Now:
New file, new audio track
record some audio, do it several times, leaving time between each event, or just cut up an event.
Activate shuffle mode and move the events so there are adjacent.
Verify in the info line that the end of each given event is the same as the start time of each following event.

RIP

I can’t get it to break now.

tried it with your settings and step by step instructions…

could not repro…

-shuffle is kinda cool tho… never used it before:P

anywho, I always use the complete signal path and mute events settings for my renders… (so I can throw all old channels into one folder in case i need it again before the end)

i have a theory though… and you brought me onto this idea… - if an event ends at 2.1.1.0 , and the next event starts at 2.1.1.0 - maybe there is some kind of overlay conflict going on… cubase sees it as one event and only renders as seperate if you remove a x.x.x.1 value?
hmm…

Cubase sees time as samples. Switch the ruler to Samples to see if what you say is true. If you didn’t do that already though, you didn’t do my repro. :wink:

this is what i did:

  1. use my key command to open the render dialogue
  2. set it to separate events, keep source unchanged
  3. press close button of rip
  4. close cubase
  5. open cubase
  6. press ctrl N , enter (this opens up a new project
  7. press F4 to the connections
  8. activate the mic input and close the window.
  9. add new mono mic audio track and arm it
    10.record some sound, toggle the rec button a few times to record multiple events
    11.set to shuffle mode and scoot the events together
    12.select all events
    13.use my RIP key command and render with your suggested settings
    14- RIP renders as one range/event (instead of multiple)

note- sample-ruler shows that event 1 ends where event 2 starts

note 2 - as soon as i remove 1 sample from the end of every event, it renders separate events normally…(with complete signal path and mute events settings)

need sleep… ttyl =)