Bounce MIDI not working as expected - merging underlying parts

In previous versions of Cubase, I could select “Bounce MIDI” and it would render the topmost regions/data, eliminating anything not currently visible. However, it seems that as of Cubase 12 it now acts in a similar manner to the glue tool, merging all data whether underlying, or “peeled back” into one composite part. I’m now getting old, unwanted parts which I obviously overwrote or hid for a reason, contaminating my final edit . Don’t want to split and eliminate parts as I go either as I like to have the option to revert, if desired.

Anybody know if there is a way to bounce/render and so as to only keep the wanted data?

You say hidden but are they muted? I have plenty of hidden parts but they are either disabled or muted and never get included in a render or export.

Bounce MIDI is supposed to glue together all the MIDI takes.
Maybe you are looking for “Render in Place” or “Bounce Selection”, which will yield an audio file?

@Johnny_Moneto no, I’m not looking for audio. Trying to glue together all of the currently audible MIDI data, as I normally do with this function.

Here’s the weird thing… I have this other region (blue in the video linked below) that is empty except for a fill at the end of the song, however I must have recorded with loop on, so I have all this empty space overlapping my other parts. When I Bounce MIDI with it overlapping, it seems to “expose” all of the “peeled back” hidden data from other regions and include that in the render (you can see the hidden data from the green and yellow regions being revealed in the video when I make the blue region overlap).

Without this part overlapping, the Bounce MIDI command functions as expected. Of course I realize that I can just peel back the empty part and voila, but it’s unnerving to know that an overlap may cause unwanted data to be included in my bounce. I wonder of there is a way to disable this behaviour?