Braces are too long, is there a fix?

As can be seen in the pics the braces are longer than the staves. Is there some way to adjust their length? I did try looking but couldn’t find anything.

You have changed some option, so check the Library Manager.
This is what I get using factory defaults:

This is what I get from the library manager

Check Engraving Options / Brackets and Braces. Or reset your Engraving Options to the Factory settings in the Library Manager.

1 Like

I did reset the brackets and braces to match factory and it says “all options match” but it didn’t fix the problem

We’re probably going to need to see a file then. If you could post a cut-down version of a file exhibiting this behavior (it can just be 1 bar long) then I’m sure someone could sleuth it out.

I just discovered a similar thing. All bracket settings default.


Here is a short clip. Please note that when I opened this to paste the example the braces were too short so I think it has something to do with Dorico similar to what jesele was experiencing.

organ braces.dorico (624.0 KB)

I found that changing this to the factory it solves the issue:


It looks like it is due to the fact that you are using a larger than standard Font Styles / Default Music Font. Set that to 20pt and it’s fixed. I’m not entirely sure why that has this odd effect, but Dorico is miscalculating something here based on that.

EDIT: cross-post as @Christian_R beat me to it.


Because braces and bracket wings are SMuFL glyphs.


I find it interesting that with the oversized Font Style setting, Dorico miscalculates both long and short. If I cut the project down further I can get this …

… but after removing the B get this:

If changing the brace size isn’t really actually an option, perhaps Dorico should remove it from that calculation.


Changing the default music font to 20 solved the problem, although I don’t think I ever changed it in the first place.

Mine was already set to 20, so didn’t solve it for me.
There is something strange going on.


Edit: I guess my problem is because it’s a 1-line percussion instrument.

Yes, adding a 5-line instrument at the bottom solves it.

and without

Hi @jesele in your case it seems to have to do with barline protrusion Engraving options (in combination with a percussion kit as Grid) set it to 0 and all is ok:

Thanks Christian, but no, I tried with default settings also. It is set to 0 in the picture


Can you send an example (Dorico file) ?

Here you go

Six Japanese Gardens.dorico (1.2 MB)

So maybe it should change when you change the barline protrusion.


Also there are no grid only 1-line instruments except for the crotales

I found that probably it is caused by the “hidden” or better said invisible clef: the clef is hidden/invisible but it seems that is maintaining the spacing as if it would be there.

(If you choose tho have the Grid view instead of Single line view (you need to create a percussion kit for it), you will have one clef for all the instruments.)