Break beams at beat boundaries not working

Hi all,

this worked yesterday and after saving and reopening the next day it has reverted to it’s original form. I’ve switched on ‘break beams at beat boundaries’ but it doesn’t seem to have any effect. It still looks like this:
any ideas? thanks in advance.

Screen Shot 2018-08-11 at 10.08.24.png

UPDATE: It was in in Notation Options>Note Grouping>Syncopation>Split at beat boundaries

Can you attach the project here, Ben? What edit(s) did you make to the music on the previous day that didn’t seem to be preserved? Was it just changing a value in Notation Options or did you also make some edits to beaming, or something else?