Brief pause during MIDI playback- AGGGHHH

Hi all,

Well, getting a new PC and Win10 SEEMED like a good idea- AT FIRST.

I’m seeing an issue now where during playback (MIDI stuff) Cubase just “pauses” for a half-second/second. Obviously, this is not good. All output ceases, and the progress bar just stops. Then it resumes on its own.

the machine is fairly beefy for its purpose Dell Latitude 2-in-1. I7 Quad Core. 16GB RAM. mSATA SSD. Win 10 home. Cubase PRO 10.0.30. I run everything though a dock, and, in a compromise due to lack of USB ports in the dock, a USB 3.0 hub.

I have no idea where to begin to troubleshoot this issue. Is it hardware? Windows? Is there possibly some bloatware on the PC that robs all the resources for some kind of scheduled task? I would think if the USB hub was the issue that the symptoms would be different (i.e. bad data/sounds on my MIDI devices), but not causing Cubase to go to a brief sleep.

I will continue to hunt in the forums, but wanted to bast this out because finally, after a very long hiatus, I have a gig upcoming! So of course this is freaking me out…

thanks!!

I found this very helpful for alleviating my issues. Hope it helps you too: https://support.focusrite.com/hc/en-gb/articles/207355205-Optimising-your-PC-for-Audio-on-Windows-10

Hi there

More info on your system is essential for us to be able to help, specifically what sound card you have plus any controllers etc.

Best Regards, Dave

Nothing wrong with your machine. I pretty sure it’s this:

https://www.steinberg.net/forums/viewtopic.php?f=286&t=163495

Thanks rtyner, thanks DaveA!

My setup is almost straight from my era…(80’s)…I use no VSTs nor audio (although the Realtek Audio Device is the one configured since I have to select something, and the “Generic ASIO Driver” results in a lot of white noise).

So it’s a couple hardware synths via USB…Motif XS and Motif XS-Rack. And a MIDI interface via USB (M-Audio Midisport 4x4 Anniversary Edition) with an ALesis D4 hanging off of that via a MIDI cable.

Any MIDI tracks I don’t have assigned to the hardware, however (i.e. tracks I’m not using) still have the default VST assigned, although I mute the tracks. Wonder if I should just un-assign those outputs.

And thanks Evertone! Looks like we were typing at the same time :slight_smile:

I looked through that thread, and it does seem like it could be related, it doesn’t seem to match exactly. In my scenario, the whole playback seems to stop- progress marker and all. But maybe they are different manifestations of the same bug, who knows…hopefully the fix is coming soon.

I did try something I found in another thread- I reset all preferences by way of deleting the directory. It seems to have helped via the two song run-throughs I just did, but only time will tell. And it’s a little disturbing: The install is like 2 weeks old and the only things I’ve tweaked are to add two midi device file scripts/devices and did this to get my midisport to show up in Cubase:

Devices -> Device Setup -> MIDI Port Setup = check [Use Device ‘DirectMusic’]

I’m the paranoid type- if I do start gigging regularly, I may just reset all preferences right before every gig if this keep re-occuring :slight_smile:

But hopefully that next maintenance fix is what I need.

Sounds to me as if Cubase is rescanning all connecting devices wich results in a pause in Midi. This includes all USB and networks devices including router.
I had this for example everytime my phone reconnected to my network when switching backround bandwith saving on or off.
Also a tablet when fully loaded up though the computers usb port made Cubase reconnect with everything and therefore pause Midi. In some cases Windows itself flushes its device manager for no obvious reasons wich also results in cubase rescanning.
Powerstate changes of Mice and keyboards might cause this.
Anything your router does also.

This issue was introduced when cubase added the USB hotplug functionality.
Sadly the Hotplug function rescans if only the slightest thing happens in your system.
For me the solution was to disconnect my Tablet wich was permanently connected as a guitar tuner.
You can easily force the issue by plugging in a thumbstick or anything else. If the symptom is the same as what you describe, you at leas know where to look. Took me years to figure that out. Audio is not affected though.

In this thread, i described it in more detail https://www.steinberg.net/forums/viewtopic.php?f=286&t=152942&p=823660#p823660

Since you mentioned Midi stopping I figured it could have something to do with the midi resetting when moving tracks or opening the editors. It could be related, if not, then at least you know there is another issue going on with midi. The issue I mentioned will be fixed for sure in the next update.

Hopefully you can find out a solution for your issue. It could be frustrating especially when working with hardware/midi. The best advice I can give you from experience is that I always do a clean install of Cubase sometimes even when doing maintenance updates. For some reason Cubase does not do well when updating versions. Goodluck!

Dudel: @#$%, you may be right. I plugged/unplugged a flash drive and it caused the sequence to pause at both events.

This is terrifying. I may have to abandon ship on Cubase or at least go back to my Win7 machine temporarily.

To be clear, the issue is not that it is rescanning all ports when connecting something. It is actually a feature. Seriously! In case you connect a usb midi device you want it to be found right ?

The problem is that cubases rescan is triggered by things that have nothing to do with your daw and there is no way to turn hotplugging off.

So your only hope is to try and find the device that is triggering it. As i mentioned the typical culprits are Smartphones, TV and basically everything thats part of your network.
Also things that are powercharging. Monitors that turn into standby also.
You could try turning off your network card temporarily. 90% of rescans are caused by ip changes and such.
Of course some USB device is likely too.

Good luck