Broken VST performance since OS update

Hello, fine people of the internet.

I’m here because I’m facing a problem with Cubase Elements 8 since today, a problem which most likely came with the latest Windows 10 OS update, and I sadly didn’t find any solution yet on Google.

Let me explain.

I bought myself a new MSI laptop recently (Core i7, 16Gb of RAM, more detailed specs below this post), and installed a Cubase Elements 8 version I had bought a couple weeks before. Everything worked fine, I could load lots of tracks and VST in my projects, record stuff without any problem, etc.
Then a couple days ago, when I turned off the laptop, I’ve installed the latest Windows updates, restarted it (took a long while to install all that shit though), and then turned it off again.

Today, I wanted to start working on the project I was already working on a few days ago (a videogame cover, with around 20 tracks, both recordings and VST) and right off the bat, Cubase tells me the licence is not working, and that I can’t run the program. Weird, but ok, why not.
I downloaded the latest version of the eLicenser, installed it, and then it worked.

I load my project, start recording bass, and after say 1’30 minute, Cubase stops working properly and says it has detected an audio drop-out, which NEVER happened before (bought this laptop a month ago, and used Cubase pretty much every day since). Then I noticed my VST performance was peaking at 100%.
I closed Cubase, downloaded the latest version available on Steinberg’s website, but couldn’t do much since I already had the latest build installed (the 8.0.40 version).
Then I restart the computer, open Cubase again, and the problem is still here.

Before this damn Windows 10 update, the VST performance was barely visible.

Now, right when I open the project, VST performance and real-time peak are showing a 20% usage.
I can’t record anything due to audio drop-outs, and I can’t even playback my track because after 2"30 minutes or so, VST performance and real-time peak both ramp up to 100% in a couple seconds (I took my phone and recorded the few seconds before this unexplained sudden burst, and uploaded the video on Youtube : https://www.youtube.com/watch?v=GdlRtF_k2_E), and it does exactly the same thing everytime I play the track.
I absolutely don’t understand why it does this.
I tried to change the buffer size, activate / deactivate Asio guard, change Asio driver, but none of this worked.
It still does the same thing as shown in the video.

I’ve purchased this computer with the hope it could run Cubase 8 flawlessly, and it did for about a month.
But this recent OS update makes it run even worse than the DAW I used to record stuff with on my old computer, which was a gigantic piece of shit, specs-wise.

So, if any of you can help me find a solution so I can get back to work, that would be awesome.


DAW : Cubase Elements 8.
Gear : MSI laptop - Core i7-6700hq 2.6GHz (up to 3.5GHz in turbo mode), 16Gb 2133Mhz DDR4 RAM.
OS : Windows 10 Family 64-bits.

Hi,

Try to download and install the latest Audio Device driver, please. Also make sure the Buffer Size didn’t change during the system update.

Hey.

The latest driver for my interface (a Line6 Amplifi TT) is already installed, but I can still try to remove/reinstall it.

And check the power settings in Windows, they are reset by the anniversary update. Or simply use the Steinberg power scheme.

Hey.

Already checked that out, the parameters are just like they were before the update.
Also, the Steinberg power scheme changes nothing, I just tried.

Ok, it’s just that the time frame 30 minutes, leads me to believe that a HD or USB device is trying to save power.
You checked the advanced power settings ?

Hi,

Try to test your system by LatencyMon.

@Peakae : Checked the advanced settings too, everything is the same as it was prior to the update.
As for the device, there’s no options regarding power settings, so I don’t think it comes from there.
@Martin : Just downloaded it, I’m gonna test the system.

Here are the results :

http://www.hostingpics.net/viewer.php?id=979177Capture1.png
http://www.hostingpics.net/viewer.php?id=556923Capture2.png

On the first one, the lowest bar was in the green area, and suddenly peaked at 8000 then 14000 microseconds (I guess ?)

The system seems to be totally OK from this point of view.

At least the system is not faulty.
So it must be something with Cubase.
BTW, the second test stressed the hell out of the CPU and the laptop started lagging heavily, but I guess it’s normal right ?

I ran the test a second time, just to double check, with Cubase.
For some reason, the hard pagefault count gave me a MUCH higher number than before.
What does it mean ?
Here are the results btw : http://www.hostingpics.net/viewer.php?id=833835Capture3.png

EDIT : Ran the test a third time, still with Cubase on.
The hard pagefault count was much lower this time (around 24000) after 3 minutes, with Cubase bugging out and dropping audio in the background. The other results are pretty consistent with the 2 other tests though. Weird.

Bump.

Still haven’t found any solution to this problem, and Steinberg’s customer service has yet to answer me.
Please help.

Try to uninstal the update or do a system restore to a prior date. If this helps you are then sure it is the update.

Don’t worry about hard page faults. These are normal.

Are you sure you didn’t do some kind of PC optimisation in the past that has been overwritten by the update…core parking for example? The upgrade may also have re-enabled any background programs or services you might have stopped running.

@Vinark : Hey. Can’t uninstall the update, and there are no restoration points I could use, so I’m pretty much stuck on this side.

@Grim : Hey. Ok about the hard page faults. But no, no, I didn’t do any kind of optimisation. When I received this laptop, I removed a few softwares I didn’t want (Norton and a couple other things for instance), then I installed all the softwares I use, including Cubase, and everything worked fine.
This update might have installed / activated some hidden programs and services (it’s Windows after all, heh), but none of the running services seem to cause any kind of problem according to Latencymon results.
Also, for a moment I thought my problems could be caused by the latest GeForce Experience update which installed itself moments before the W10 update, but I tried installing the previous version and it didn’t change anything.
Also tried to deactivate GeForce Experience, but the VST performance / real-time peak were performing even worse, with a load of 30% on my opened project, and for some reason, the bars ramped up to 100% although the project was idle. No playback, no nothing.
I noticed Cubase’s CPU usage goes around 25% of the total power of my CPU when it’s bugging out, when it barely reaches 8-9% usually with the project loaded.
I really don’t understand what’s happening.

Steinberg contacted me and told me to do this :

Initialise Cubase preferences :

To do so :

  • Close all programs.
  • Open the ‘Run’ command prompt.

Windows 7, Windows 8, Windows 10: Press the Windows logo key + R simultaneously.

  • In the command line of the ‘Run’ window, enter this path: %appdata%/Steinberg
  • Locate the folder which is named the same as your Steinberg program, for example ‘Cubase 8’.
  • Rename it (for example to “Cubase 8 hidden”) in order to hide it from Cubase.
  • Important: If you find folders of previous Cubase versions, make sure to hide or remove them, too.

Next time you start Cubase, a new folder with fresh preferences and default settings will be created - which hopefully fixes the problem you’ve experienced.

Preferences that you have grown accustomed to and that have taken a lot of time to configure - the key commands (Key Commands.xml) for instance - can be copied from the inactive folder to the newly created active preferences folder at a later point.

But it didn’t work.
Not completely.

Actually, the real-time peak bar is barely showing (1-2%), which is great, but the average load bar behave just the same : high charge right from the beginning, and suddenly ramps up to 100% after 2’40 minutes of playback for no reason.

It is strongly recommended that you do not have Geforce experience even installed. Only the basic Nvidia driver. this has cause many problems for people. I believe it’s also fairly typical that issues do not show up in latencymon with graphics problems. This is where I would focus your attention in the first instance.

Other than and assuming this was the AE 1607 update, it is indeed possible to uninstall as long as you do it within 10 days. I’m afraid I’m not too sure how you can stop it updating again though…but I’m sure there are ways if you google it

Well, I might as well toss Geforce Experience since I’m not even playing on this laptop, but as I said, Cubase performed even worse when I tried to simply deactivate it. Doesn’t hurt to try though.

Still looking for a solution.

As expected, kicking out GeForce Experience out didn’t change anything, sadly.

VST performance still act weird, and even show sign of activity without anything opened, just the software.
Ran another couple tests on Latencymon after changing some stuff in the BIOS, still the same.
But I did notice something strange : all 8 threads of my CPU were running the tcpip.sys process, and this process shows a much higher latency than any other else (roughly, 0.7 for this one, against 0.2 for the second in the list).
Don’t know if it has anything to do with my problem, but since Cubase was opened and running while testing, at least one of the cores should have been running it, if not excluively, at least partially.

Oh, and if I play anything in Cubase while testing, the “average load” bar of the VST performances with go up to 100% and back to 0 at regular intervals (I’d say twice each second), obviously causing massive stuttering.
It didn’t do that when I ran those tests before uninstalling/reinstalling Cubase.

Didn’t hear anything from Steinberg’s customer service since friday.
Guess they abandoned me. :v