Buffering and Latency help please ?

Whats the best thing to improve with regards to hardware on my laptop when it comes to buffering and latency ? would a new faster processor help or will a new hard drive make the difference ??

I get a pip or like a mini gap in songs every now an again. Ive messed about with the sample rate an that but the latency is a bit annoying. I just want to be able to hear, play and record everything in real time without any pips.


would a new faster processor help or will a new hard drive make the difference ??

Very unlikely.

For good performance you need a decent audio interface with an ASIO driver…do you have one or are you trying to run on the built in soundcard?

Thanks for the reply.

I’m using the steinberg ci2 as my interface.

Would a good sound card sort it maybe ?

CI2 should be able to work fine without dropouts.

If you have wi-fi on the laptop then try disabling.

Chances are your problem is to do with a setup issue but you’re not giving much to go on. List your PC spec, O/S, Cubase version, driver/buffer settings, say how frequent the dropouts are & check if they are regular or random.

Download and run this (assuming windows):


See if you are having system problems.


I second Ron’s advise.
Also, open Resource Monitor from the Task Manager to see if other applications are stealing CPU power.
Laptops are configured to conserve battery life, so there are changes to optimize performance to stream audio more smoothly. (Switch the power options to high performance, etc.) I recently followed the steps on Sweetwater’s support page (Sweetcare) and made a big improvement in my laptop’s performance. No mare clicks, lower latency.I my case, there was a useless toolbar that was eating CPU power.

Thanks for the help philskeys, ron and grim.

So i tried the latency check. I get mostly low end greens and a few yellows. The only time i get the odd red is when i hear the computer start to work. As soon as the computer stops makin the noise the red and yellows go too.
Actually, scrap that, ive just noticed a couple of reds when the computer was quiet. Definitely happens when u hear it workin though. every time. Any ideas what to do ??

Grim - Cubase 6.5, ci2 interface, toshiba satellite laptop, windows vista, 4gb ram,intel pentium cpu t3400 @ 2.16ghz 2.17ghz


Here is what I would do. It’s a bit tedious, but will hopefully help you narrow things down.
Run msconfig.
Choose selective startup.
Uncheck all 4 items and reboot.
Run dcplat. I would assume all will look good at this point.
That means that something that got turned off is causing issues.
Now you basically turn things back on until you find what is causing issues (it could be more than one thing)
Check SYSTEM.INI reboot and check with dcplat
If good - check WINI.INI as well and check with dcplat
Most likely those two won’t have issues.
Repeat with System Services. There is a good chance that you may find problems here.
If so click the services tab and start turning things back on on a service by service basis. I usually turn them on in chunks (one at a time would take forever as you need to reboot each time)
Same process for Startup Items.

This will hopefully narrow down the culprit(s)

I had this problem on a laptop and narrowed it down to the builtin wireless card. In my case I was able to update the wireless driver and that fixed the issue.


The only time i get the odd red is when i hear the computer start to work

With nothing running why is the computer “starting to work”??
The “odd red” will almost certainly be the cause of your dropouts.

There are also some instructions to trace problems at dpc latency checker site. (By disabling stuff in device manager)


Have you disabled/do you have wi-fi?? This is arguably the most common cause of problems.

Cheers ron. Looks like I’ll hav to give that a try on my next day off. Songs like its quite long winded. Worth a try though.

Grim, I’ve got wifi. But it hasn’t worked for ages. Maybe that’s the reason. I’ve turned it off but maybe I could go further and disable it completely somehow ?

  • looks quite long winded. Not songs :slight_smile: music on the brain

I just went thru latency hell recently and many of the issue with laptops are due to power saving settings and services running to extend battery life. 50% of what I read while I was battling my issues was about laptops and the most recognized cause.

Try setting everything to full on to see if that helps. If you got any yellows or reds its gonna hurt your audio performance.

In your system control panel, under the device manager, find your network adapters. Disable all of them. That’s a big problem fixer. Even if your wifi doesn’t work, it still may be searching for routers if you don’t disable.

go into your device manager and disable:

Microsoft ACPI-Compliant Control Battery

there might be more than one entry.

you can also try disabling your DVD drive and see if that helps.


trim ur pc for performance , rather than features , disable all those desktop pix , keep a black background , some thing like the win 98 , storm VGA , consumes less power n less glare on your eyes… will definitely give your processor @least 15 percent more performance … hope this helps s

so i finally got a day off work to hav a go at sorting the problem.

I made the laptop for high performance use. Disabled a load of stuff and now all the reds hav gone on the latency check. Not sure which one exactly made the difference but they’re gone. Unless my laptop is lulling me into a state of false sense of security !?? :astonished:

Thanks to everyone that responded, your help was greatly needed !!

I hate latency

And a cheapish improvement to speed things up is to buy more ram.