BUG 6.0.2 - Horrible Warping Behavior after looping a while

I was testing some VST plugins on a 2-bar WAV drum loop just to see how they behave. After many loops, the drum loop started to play strangely–the first beat (a kick drum) seemed to be warping. The difference was VERY noticeable. Even when I removed all effects from the channel, the warping persisted. I’m going to do some more experiments and see if this happens with an empty template… stay tuned.

Has anyone seen this behavior?

EDIT: 100% repro… this is REALLY bad, as once you start hearing it, the project actually RENDERS that way too. All you need to do is insert a drum loop into an empty project, loop the project and hit play… that’s it. Eventually Cubase will start to mangle the audio.

REPRO:

  1. Start a new project. Choose Steinberg’s “EMPTY” template. (Note my default is 44.1kHz 32bits. The project is 120bpm)
  2. Open Loop Browser.
  3. Double-click a drum loop. (Note: in my case, I chose Drums on Demand: Warm & Natural/125 BPM (Earthy)/!Ch.wav – but I reproduced this bug with other drum loops as well. This particular loop is 2 bars.)
  4. In my case, I have Cubase set to convert the 24bit loop to 32bit.
  5. Go to the loop in the new track and select it and press P to set the loop length to the Part
  6. Turn on looping in the transport bar.
  7. Hit play.
  8. Wait about 10 minutes while it loops.

Result: The beginning of the loop becomes badly warped. And Worse, if you choose File->Export->Audio Mixdown, the warping actually renders in the mixdown too! This is “data corruption” of sorts.

Listen to Cubase Looping Bug.mp3 for the bug.
Cubase Looping Bug.mp3 (98 KB)
You can hear an MP3 of the original file in the second attachment, !Ch.mp3.
!Ch.mp3 (96.8 KB)
OMG this is bad!

In case you want to reproduce this bug on your own, attached is the project that reproduces this bug.
Cubase Looping Bug.zip (1.09 MB)
As you can see, it’s the standard “empty” project with a single 2-bar loop inserted. No VSTs added. No settings changed at all.

Simply press play and walk away for about 10 minutes.

Come back and you will hear the horrible warping on the first beat. The longer you wait, the worse the warping.

Once you hear this bug if you render a mixdown, the warp will be in the mixdown.

Hello,

thank you for the projects. I occured here after 15 minuts or so. I will pas this on (28680)

Cheers,

Chris

Thats actually an insane bug :open_mouth:

Hope this is fixed ASAP!!

I think it is time Steinberg starts planning more frequent updates for bug fixes… Update every few months is just not enough anymore. As Cubase grows, bugs get more and more “esoteric”, almost as Cubase is developing artificial intelligence, trying to make itself alive, humanized,… Trying to become analog?

Steinberg, how about monthly maintenance update for bug fixes?

Thanks Chris!! If you get any information on a temporary work-around until this gets fixed (short of closing down and restarting the project) please let me know!

yep,

happens 2me almost everytime

http://www.steinberg.net/forum/viewtopic.php?f=19&t=7805

Drat, I had just decided to upgrade to 6.02 as the cracks & pops cause had been found (kudos to Andi and Early21) and now this.
To important to get lost in some bug fix list as this is really broken, back to 6.01 and waiting for next update.
And thanks to Lights for highlighting it.