[BUG] 6.0.2 replace audio in video not working PART2

Following on from this thread which I believe was erroneously marked as solved:
http://www.steinberg.net/forum/viewtopic.php?f=19&t=8044

Trying to replace audio in video in a particular file, on a local drive this time, progress bar appears, no errors.

Play video … original audio still there. Replacement has NOT OCCURED.

Source video is a .MP4 file. H.264 video, AAC Audio.

If this format of video/audio is not supported for audio replacement then it MUST inform the user of this, and that it cannot replace the audio. It should not give the impression the process occurs successfuly.

Worked when I made a copy of the file and converted it to AVI MJPEG WAV.

Clearly there are codecs that Cubase doesn’t like replacing audio in video for. That’s understandable, but at the very least Cubase needs to actually report the failure rather than making you think it’s worked.

Don’t you have to select the format for the audio mixdown to do the replacement…& AAC isn’t an option as it’s not supported??

Regardless…a message that the format does not match the video would be more user friendly.

Acknowledgement from Steinberg / Mods would be greatly appreciated.

I had a problem using the H264 format on Mac. Converted it to another codec with QT Pro and it worked.

I posted this, but no one replied.

BUMP!

Steinberg really MUST be forthcoming about what video/audio codecs can be audio replaced in video.

I’m guessing this would be a seriously big deal for Nuendo users … of which I am one! Really must get around to registering it :wink:

I have found that when working with a video file imported into cubase, do not try to replace the audio in that particular file. Make a copy of it, put it in another folder, when you export the audio you want to replace, also export to the same folder the copied video is in. Then use the “replace audio in video” funtion from cubase and it works everytime regardless of what codec was used.
And of course you know the file lengths must match, so set your markers to length of the video when exporting audio.

When you reprot a bug you should wite a decent repro.
I couldn’t reproduce. When you replace the sudio of a file that you have already imported in Cubase try to remove it from the pool and the trash and then to import it again. Then the replaced audio should be loaded. As johngar wrote I would also rather advise to work with copys.

Gr,
JHP

Apologies for not replying to this sooner, have been incredibly busy the last month and haven’t been on the forum.

I’m not sure how more detailed my repro could be. Replace Audio In Video is one command.

I was not using the same video as is in the project. It was a separate copy of the video file.

The question is, are the video/audio format/codec standards that Cubase cannot replace audio in?

I had a similar issue. The progress bar said 100% but the whole thing froze. A dupliate file had been created in the folder but it had the original audio. I restarted and tried again - the same thing happened. Only this time I switched the monitors off and went to bed suspecting the progress bar was wrong and it was still mounting the audio. Next morning the audio had been properly mounted.

Was your file a very large one?

Not quite the same behaviour I was getting - mine wouldn’t get stuck, it would actually complete unusually quickly - it would go 1 percent, 2, 10, DONE! And then I’d open the video file and it still had the old audio in it.

As long as it is quicktime it has worked for me, are you sure the audio file is the same length as the video?

IT Works, I duplicate the .MP4 VIDEO FILE on other folder (This is the one cubase is not using),
I Exported a .WAV file as Audio Master, (44 khz,16bit) , then from the proyect asked for audio in video file replacement.
I am using Cubase Pro on Mac (Mavericks).

I hope it works for everybody,
let me know.

Dhruva.

I got it working yesterday. Today, using the very same method, it does not work. Frustrating