Bug: (8.02) Very odd behavior with Rename File Dialog (F2)


I need to walk you through this to see if what I seeing is normal:

  1. I open a audio file in WL - any file from a recent location - in this example File 1 in a folder called 09-16-2013

  2. Once the file is open - I press F2 to rename the file

  3. In the Rename dialog - the file name is displayed correctly as is the current path to that file - let’s say it’s R:\Audio\09-16-2013

  4. I quite frequently need to change the location of the file (NOT the filename) - so I click the Change Folder checkbox - which opens the file path for editing.

  5. In the path that is displayed - I change just the very end of the path (09-16-2013) to be a new folder called 09-17-2013 and click OK

  6. WL tells me that the new folder path does not exist - and would I like to create it. I click OK (UI suggestion - this dialog should actually have Yes and No buttons - Not OK and Cancel)

  7. WL then posts a bizarre message telling me that the file could not be renamed (I am not renaming the file - it’s name is unchanged) - due to file being write-protected or the file is in use. Logic: Of course the file is in use - am I not trying to move it to a new directory? This message makes no sense at all - it’s almost like the UI is telling me I cannot proceed…

  8. Then - if I look over in Explorer - while this weird message in #7 is on screen - WL went ahead and moved the file anyway - over to the new folder location of R:\Audio\09-17-2013

  9. But - even tho the file (now secretly moved) remains open and ready for edits - in the Wavelab application window at the extreme upper - WL still is displaying the file with it’s old path of R:\Audio\09-16-2013.

  10. Even more troubling - is that the file was moved to the new directory in #8 - there is no sign of this file ever being opened at all in WL under the Recent Files dialog or off the File menu or anywhere. If I need to return to this file (like I almost always have to) - I have to go hunting for this new directory to open the file.

Would like some input as to what is going on here…



I can’t reproduce. Can you? Can you give a picture of the “strange” message you speak about?


Here are some screen of the messages.
Cap 5 - Message 1.png
Cap 6 - Message 2.png
I also recorded the entire process to an MP4 vid so you can see the entire thing from start to finish…let me know if I can send that to you for review.



I think the procedure you follow is clear.
Is is always reproducible?
Is the file part of a montage already opened in WaveLab?
Please give me an example of a full file path/name, before / after, than fails.

“R” disk drive is local or networked ?

In case of a NAS, access to files uses a dedicated network file sharing protocol such as NFS, SMB/CIFS.
A lack (or a twist) of user priviledges could explain such behaviour that not occurs on a local drive.

In case of a local drive… I’ve no idea.


Yes - this is 100% reproducible. It has been happening in v7 as well. However - after thinking on this a bit more - especially since it was happening on v7 - I think I need to check out the actual security settings on this “R” drive. Back when I rebuilt this machine (Nov 2012) - I do remember having some Windows/NTFS stuff rearing it’s ugly head…

So - I am going to try the same workflow - but to a different drive and see how WL handles it.

If you are not seeing anything out of the ordinary on your end - then it must be something local to me.

Will report back with my findings…




I revisited my workflow and did some very deep checking into my main DAW, it’s hard disk security etc and can’t find anything out of the ordinary. I still get this messgae series when attempting to rename a file…I am going to create a fresh file tonight and document each step…with some screen shots for you again…

I cannot figure out where the problem lies. Is it possible for you to check the code and determine why the message " The File cannot be renamed. Please make sure the disk is not write-protected nor the file already opened"…is being displayed. What exactly is Wavelab looking for when it displays this message.

My drive is not write protected and the file being renamed - is in use - logically - since it’s being renamed. But I would like to get a sense of what WL is doing and checking for when it decides to display this message.



This message is displayed right after calling the rename function from the operating system, in case of failure.
I your step sequence, don’t forget to show the full path names.
Also, try with a single audio file open in WaveLab, nothing else.


I just walked thru this again - opening a single file in WL from locations across all 3 drives on the PC - and all three cases causes that message to appear. It’s not a rights or security issue. I even ran WL as “admin” and as a normal user - with the same results all three times.

My next question is this - why does this message “The File cannot be renamed. Please make sure the disk is not write-protected nor the file already opened”…appear (as if to indicate failure) - and then WL completes the request successfully anyway by moving the file in question to the new folder in question? This makes no sense.

Either there is a real failure (file cannot be renamed, folder cannot be created or file is actually locked/write protected) and the message displays - but nothing else should happen - certainly not file movement. Or the file gets successfully renamed and moved to the new folder and no message appears at all.

Seems WL is getting a false positive from the OS on failure and then kicks up the message. But then the file is moved correctly?



I still can’t reproduce the problem. Do you have the chance to try on another computer?

Bruce and PG, I don’t know why it’s not happening to PG, but I get exactly the same problem here with WL8 on Win 7. It even happens with WL6 on Win XP (same error messages). It doesn’t happen if you do the same thing from the Files tab in the Montage, but that doesn’t help Bruce much. The problem seems exclusive to the Audio Files workspace / area.

Interesting! I had this same scenario on WL7 as well. Cannot remember far enough back to know if it happens on WL6 :slight_smile:

To be clear - I am not using the Montage. I have never used the Montage. This error involves the Audio files area exclusively:

  1. I can drag in or use the Open icon to open a single file.
  2. Hit F2 to open the Rename dialog.
  3. Then click the box that says Change Folder.
  4. The path field opens and I then type a new folder location to the end of the path .
  5. If I click OK…Wavelab posts two messages
  6. One asking if I would like to create the new folder…I click OK
  7. And then the second - telling me the “The File cannot be renamed. Please make sure the disk is not write-protected nor the file already opened”
  8. I click OK on that - and the file gets moved anyway.
  9. But - with the move - the file - which is still open in the editor - does not get it’s paths updated nor does WL record any knowledge of the file ever being moved.

I can do this all day long with any file.

PG - To answer your question - I really do not want to install WL on another computer…but it’s an option.

Now that we have another user with this error - I think it would be of more value for you to tell us what happens when you follow these steps. Do you get one message only? If/when the file is moved on your machine - do the paths get updated on the dialog boxes and in the File History areas?


To answer your question - I really do not want to install WL on another computer…but it’s an option.

This is to know if this is related to your setup.

when you follow these steps. Do you get one message only? If/when the file is moved on your machine - do the paths get updated on the dialog boxes and in the File History areas?

I follow your procedure and encounter no problem, I get one message only and all paths are updated.
I will see if someone can reproduce this at Steinberg.

Well - now that we have a couple of us getting the same issue - (and it’s dating back to older versions of WL) it’s obvious that we have a problem somewhere.

What is really troubling me is that WL posts this error BUT moves the file anyway. This is massively frustrating since the actual physical file is moved out of one place and to another and cannot be easily found later. The lack of recorded history and especially no filepath updates make this a real problem.

Lastly - I can replicate this issue whether I physically type a new folder in that path field OR if I click on the folder icon and shell out to Explorer and create a new folder out there using that interface. The same errors come back every time.

I will try a few more things - like adding an external drive or even installing WL8 on another machine. This is a last resort due to the registry mess it leaves behind - but I need to solve this thing.

Hope to hear back from you on this. I will post more results as I get them.




Small update from a session last night. I needed to rename a file that was loaded in the editor - so I pressed F2 as per usual. This time - I just needed to change the name of the file - NOT the location - so I left the Change Folder checkbox off. I renamed the file and carried on with no issues whatsoever.

So in my case - I only get into trouble when I want to change the folder target - and NOT rename the actual file itself.

Not sure if this helps or not.