BUG: all linked tracks are not selected in the Project window

Cubase 11.0.10 Build 321
Windows 10 Pro 64bits version 20H2 OS 10.0.19042 Build 19042
CPU: AMD Ryzen 9 3900XT 3.8Ghz
MB: ASUS TUF GAMING B550-PLUS Bios 1401
RAM: 4x16GB of DDR4 Crucial Ballistix Desktop Gaming Memory Kit, red @ 1600MHz
GPU: Gigabyte GTX N970IX OC-4GD
SSD for Win10 + Cubase: Samsung SSD 970 EVO Plus 1TB Nvme M.2
SSD: Samsung SSD 860 EVO 4 To SATA3
PSU: Corsair 750W Gold tier1 on LTT
Case: Be Quiet Pure Base 500DX

Preferences used: UserPreferences.zip (15.3 KB)

    1. Create 3 Audio channels and name them A, B and C
    1. Open the Mixer and link A and B with Volume, Mute/Solo, Selection, and Record.
    1. Still in the Mixer, Select C
    1. Select A or B. Result → A and B are selected. GOOD.
    1. Close the Mixer
    1. Select C in the Project window
    1. Select A or B in the Project window. Result → only A or B is selected. NOT GOOD.

I noticed another bug that appears randomly so I can’t reproduce it but encountered it several times while typing the step by step procedure above. I never could reproduce it when trying to. What happens:

    1. Create 3 Audio channels and name them A, B and C
    1. Open the Mixer and link A and B with Volume, Mute/Solo, Selection, and Record.
    1. Mouse click on Solo on B. Result → Randomly, only B is soloed instead of A and B.
      Unfortunately I could only catch the result on video: https://youtu.be/CLYvJ_YfBRI

Feature request: Please (re)add the ability to quick link tracks within the Project window with a right click like it was possible in Cubase 6.

That sounds like a Preference. Have you checked the box in Preferences > Project and Mix Console > Sync Selection in Project Window and Mix Console?

Another thing that could be wrong is the Link Group settings > Selection or Record/Enable/Monitor.

I have only ever linked tracks in the Mixer, I don’t know of a method in the Project Window.

Thanks for your reply. Unfortunately, with this method, I have to go through the channel mixer, find the linked tracks and select them so they’re both selected in the Project window and close the Mix console.

In Cubase 6 I would just select one of the linked tracks in the Project window and be done. Both tracks were armed and ready to record, just with one click.

I don’t get why the linked tracks behave like they should in the Mixer but not in the Project window:
In the Mixer, if I select one of the linked tracks, both are selected.
That’s not the case in the Project window, with the “Sync Selection …” settings checked or not.

You are right, I get the same here. I checked in Cubase 8.5 and it is the same there too. I agree that at some point it behaved as you say, but I don’t have 6 on my system anymore to confirm here.

Try this: Select one of the the linked tracks in Project Window - just that track highlights. Now hit solo and cancel. Are all now selected? That happens here…it is a workaround, but doesn’t make great sense in workflow terms.

If I am interpreting your request correctly highlight all the tracks you want to link in the mixer. Right click over one of the highlighted tracks and click Link Selected Channels.
In the window that comes up tick all those qualities you want especially Record Enable/Monitor. Then when you hit record all the linked channels will record.

@Silhouette. If you do as you say, but then select a track from the Project menu, only that track highlights and only that track drops into record. I think that’s what Innervision is commenting on. If you toggle record or solo, then all linked channels highlight and all will be set ready to record

Thanks for the suggestions. But… like you mentioned Parrotspain, the goal here is worflow efficiency. And having to fiddle and mess around in the Console Mixer just to be able to arm record 2 tracks is not what I call efficiency. I do my recordings from the Project window, not the Mixer Console.

I think we can call this a bug as the behavior is not consistent between the Mixer console and the Project window. What do you think?

I assume that you are talking about the Arrange Page? As far as I know it has been like that for a long time. Can see your point, but I can also see that setting things up like this can be useful. If you select a track you then highlight record on one of the unhighlighted tracks all your link tracks activate record. Which is the same number of mouse click as selecting one track and highlighting record on that track. That’s how I have been doing it for years! I guess it is a pain, but I have known no other way!

Thing is even if the tracks are linked in the Mixer, this linked state doesn’t work in the Project window.

It should be only one mouse click: I select one linked track which actually selects all linked tracks and arm them for recording. This works in the Mixer but not in the Project window for some reason. Are the tracks linked or not?? Yes, so they should behave like linked tracks everywhere in Cubase. Hence, bug. Please don’t say that’s a feature :sweat_smile:

Well you are right. However, it does mean that if you want to re-record a correction on one track you don’t have to unlink the tracks. However, to do that you have to click on another track and go back to the track you want to alter. I concede that there should be a little more consistency. I guess I have never thought about it.

I record one guitar track with 3 microphones so I need these 3 tracks to be linked. It’s easier to edit and to record (and to avoid mistakes, like mistakenly moving events). I will never have the need to unlink them to record a different take on only one of these tracks. If I need a different take, it’s all 3 tracks/microphones or nothing.

Again, the behavior is correct within the Mixer, so why can’t I just select one linked track in the Project window and be done with it? (meaning having all
tracks selected and armed) This is really nonsense, that’s why it should be a bug.

Anyway, thanks for looking into this!

1 Like

If Mixer and Arrange Page (Project Window sic.) are linked, then they should act in the same way. I would stop just short of calling it a bug as nothing is strictly speaking broken, it is more an oversight or inconsistency. But I definitely think it needs to be pointed out in case Steinberg aren’t aware of it. I can’t see an advantage in it being set up like this.

1 Like

Perhaps what should be requested is for the Link Selection Window to have an extra entry for Synchronous Record for those like you who need it. I often link my guitar tracks, or vocal tracks but don’t need to record more than one track at a time and so for them to always go into record would be a pain. However looking at the practicalities I will now be using The VCA fader to link those groups.

@Silhouette. It’s a fair point. Another option might be to add a global or individual “Suspend Links” to the Mixer

One thing I perhaps should have mentioned is that I use a Desktop PC with 3 monitors and always have the Mixer in view. I can see that with a Lap top this also introduces workflow issues.

You could also stash the tracks in a folder and arm all of them from the folder.

But I’m with you. There should be consistency of functions, whatever is possible in the mixer should be possible in the project and vice versa.

1 Like

@Silhouette. I have quite recently added a third monitor. I love the speed at which I can move around. It is clearly important that Cubase translates well to a laptop situation, using lower zone etc.

Sorry but this clearly a bug. It doesn’t even behave like it should in the Mixer.

I set up 3 linked Audio tracks in the mixer , linked with Volume, Mute, Selection, and Record.
In the Mixer:

  • When I move the Volume slider, all 3 Volume sliders are moving
    Project window:
  • When I move the Volume slider, all 3 Volume sliders are moving

In the Mixer:

  • When I click on Solo, all 3 tracks are Selected and soloed
    Project window:
  • When I click on Solo, all 3 tracks are soloed but only one is selected → hence BUG

Same thing happens when only clicking on one of the linked tracks to select them: works as expected in the Mixer but not in the Project.

In Cubase 6, after linking the tracks I could with one click select all 3 tracks and arm record them.
In Cubase 11, even after linking the tracks, I have to manually select all 3 tracks to arm record them.

3 clicks against 1.

But this issue goes further for me: having the tracks linking correctly in the Project would avoid me the displeasure to redo takes that were half recorded because I’d have forgotten to arm record all the corresponding microphones tracks. That would really piss me off.

ggmanestraki The folder tracks could have been a workaround if they were not keeping this arm recording state at all time even when selecting other tracks. So we have to not forget to unarm them to move to other tracks. I actually use them for my guitar recordings but not for this purpose.

1 Like

Yes, that’s true. After I route my tracks, I stash them in the folder and pretend that I’m recording to a single track (the folder). I rarely forget to press R after I’m done recording.

But enough of that, you are used to your own way, and it doesn’t work anymore. Why don’t you add the #issue tag to the thread, maybe someone from the team sees it and they confirm/deny the problem.

Just curious, did you just click on the Record Enable button on one of the tracks and all three were armed? OR, did you have to first click on one to select them all and then click on the Record Enable button?

Edit: Are you using the same Preferences as in the other issue thread?
Bug with the solo behavior: solo applied only once on 2 presses - #8 by Innervision

1 Like

For me not to be able to record on one track in a linked group would be irritating, especially when you are recording a number guitar tracks. It has to be an option in the Link Tracks window. Have you posted this in the bug threads?