BUG! All recording with a click must happen from a bar and never a beat!?

My Cubase 10 works fine in this regard. it records on the beat I put it on.

Just tested and the recording of audio tracks starts exactly where the cursor is located.
Do you by any change have a midi track record enabled as well?

Thanks KHS for providing something to try. It’s great to see someone trying to contribute and not be contrary. Unfortunately, turning off Snap to Grid didn’t do it. I tried different snap modes and turned snap off completely and still the cursor jumps back to the bar. I’ll retry from a new project and see if this isolates the issue. I’ll also be calling support again to see if they have any update on this issue.

KHS - concerning MIDI record enable - No…a MIDI track is present, but the one track is not in record ready mode.

Are you recording in cycle? I usually do and I’ve never found it a problem…
I seem to recall there’s a preference somewhere like “start recording at left locator” or something. Might be a clue there? Or perhaps play with the preroll settings?
If all else fails maybe just punch in manually where you need, then snap the new audio to the best you want it to start on…? Just as a workaround…

UPDATE: I installed Cubase 10.0.40 fresh on a completely different Windows 10 machine that has never had Cubase on it. It’s running version 1809. (other problem machine was version 1903) The problem is still there. This confirms that the issue is not because of an upgrade path from a previous version of Cubase 10 AND that it’s not project or preferences specific. The problem is there right out of the gate. I’m calling support again tomorrow to beg for some attention to this.

SIDE NOTE: Folks here have said that they can’t replicate this issue. I can’t believe that with the testing I’ve done and simple recreation of the issue. To remind anyone interested in testing about what I’m doing in quick terms: new blank project, insert audio track, arm track for recording, adjust metronome to click during count-in only, change grid type from bar to beat so that it can start on beat 3, place cursor at beat 3 of any bar, hit the asterisk on number pad to start recording - cursor jumps backward to bar beginning. (beat 1)

So angry.

Turn off Count-in. Earlier versions behave same way.

I could turn off count-in, but that would mean working around the issue instead of resolving it. The point here is that this is unacceptable behavior. I should be able to record from anywhere with a click, and furthermore, as a community, we should be demanding either an explanation or a fix. I’m getting neither from support.
I’ve been recording with a click for over 30 years and of course at any arbitrary starting point I desire or require.

I’m curious about your comment on this happening in earlier versions. Did you mean major versions like 8.x and 9.x or minor versions like 10.0.30? Has this really been allowed to go on for years?

Thanks for your input.

I said “Count-in” not “Click”. You can use Metronome Click while recording.
Count-in (Precount) and Pre-roll are different thing.

I have good and bad news for you. It’s not a bug if you’re the only person experiencing this but a setting within Cubase or your system. I promise you. I’ve been using Cubase since the 90s and it’s never done this. The good news is that you can fix it now but… you will need have an open mind and inspect your settings.

  1. Is snap turned on in the arrangement window? If so, it will jump back to the bar if the snap region is set to bar. It is the symbol at the top of the arrangement window that looks like >|<

  2. Press F2, then click on the top left box on the transport control that contains text. You want it set to Punch In/Out and Start at Cursor. Also just check that punch in and out are filled with 0s, eg 0:00:00.000

  3. You might like to use under File=>Preferences, Return to Start Position on Stop. This makes it return back to where you start from. If you find that playback is also snapping to the bar then you’ve probably left snap on.

  4. Any connected control surfaces, control apps or rewire programs could be messing with it.

  5. If you use a firewire interface under windows, you might need to use the legacy firewire driver or stop using the legacy firewire driver as clocking info might not report correctly.

Currentsound- It’s good to have such a long time user join.

Where to begin…
It’s not just me. It’s support too. We reproduced it together. I from my system and he on his. I’ve also reproduced it in an entirely different environment to further prove beyond a shadow of a doubt that it’s baked in right out of the box.

Apples to apples…
All I can conclude is that something on your system is therefore different from mine. Believe me, I’m jealous.

Humbly checking myself…

  1. If snap is turned on, the cursor snaps to the bar. If snap is turned off, the cursor also snaps to the bar. So…either way, I can’t start recording from a beat other than the 1 of the bar. Lets clarify - You wrote, “snap region is set to bar” within #1 of your reply. Humor me as I use the terminology within Cubase so that we may communicate as clearly as possible. I’d like snap engaged or turned on in what’s called the “snap type” toolbar. This toolbar reflects ‘grid’ as it’s default setting. Furthermore, located directly to the right of the snap type toolbar is the “grid type” toolbar. Here the setting is ‘beat’. The default setting is ‘bar’. I had to change this setting, otherwise the Cubase cursor will indeed lock to a bar and placing the cursor on a beat is not allowed. Now I’ve checked these settings, and I believe we’re saying the same thing using similar but different terms. However, I can’t locate any setting called “snap region”. Can you point out how to access snap region? Or…are we indeed saying the same thing?

  2. Pressing F2 brings up the old floating transport bar. I’m completely confused from here. The floating transport bar on my system only goes left to right in a single row, so “top left” means??? I see no text except when I hover over a field and get the pop up explanation of the toolbar. I can expand the punch in/out toolbar to reveal 4 fields that can contain #:#:#:#. From left to right they are: Left Locator Position / Right Locator Position / Punch In Position / Punch Out Position
    I’m not activating punch in/out, so the fields are inactive or grayed out. If I do engage punch in/out, the fields light up, but will not accept 0:0:0:0 as this is not a recognized or acceptable time. Finally, if I want to ensure that Cubase will “Start at Cursor”, that’s located in the bottom most section of the project window in what’s called ‘Common Record Modes’. This has been left at the default which is, as you’ve said, “Punch In/Out” and “Start Recording at Project Cursor Position”

  3. I usually do engage the ‘Return to Start Position on Stop’ setting. However, not here in my virgin system which is being used as a control for this testing. This can be ruled out.

  4. No control surfaces, apps, or rewire programs are used. These can be ruled out.

5)No firewire. I use an Apollo Thunderbolt 3 interface from UA.

I’ve played around with the settings I believe you’re referring to, and no fix has been found. I would really enjoy seeing your system work correctly. If you’re willing, I would love the opportunity to do a Teamviewer session with you. This would expedite knowledge sharing. If you’re willing, please message me.

Actually, can confirm on 9.5.50

I think this behavior is related to “Count-in” only.
FYI, Studio One behaves same.

Use Pre-roll (Deactivate Count-in), Activate Metronome Click, Check “Click while Playing” in the Metronome Setup
(If you don’t want clicks while record is running, uncheck “Click while Recording”.)

No resolution. No admittance this is a bug. No more responses from support on how to resolve it or overcome it other than lame workarounds. I’ll make them address this by bugging them every week, resolution or not. Resolving bugs in a forum is a joke and so is their support. Very un-pro. I’m pissed.

Hi there, you maybe angry, so please stay calm and I can show you how to solve your problem.
If you are on Cubase 9.5 the Metronome setup maybe disappear from transport bar and you can take it back, following below topic:

Then you can de-activate Count-in, this is an optional pre-count, at least 1 bar (or more, you can change it using metronome setup), to help giving player an exact time to be ready for playing.
I use Cubase for 15 years, and this is an option that I never use. So I can understand how bad you feel.
Be cool, you may not want this, but other thousand artists all over the world need this.

I also attached a photo of pre-count (or Activate count-in) in the transport bar, so you can see it.

Since you said you didn’t want to reset your setup, I believe you never install a fresh copy of Cubase.

Good luck, bro.
Screen Shot 2019-11-16 at 9.52.06 PM.png

Hello!
Got the same cursor behaviour here. Never paid attention to this, may be just because there were no such tasks. Always started the recording from the bar.
Thank you for mentioning it here!

I got couple of thoughts:
1)In my case the cursor behaviour is connected with count-in mode on (when it is off everything works fine). Count-in repeats the click pattern. Let’s say we’re at 4/4 and we count 1,2,3,4 and start. So I think the creator’s logic is clear. They didn’t want us to count 3,4 start. At least partially I agree with them.
2) The support behaviour is ridiculous. I suppose they are not Cubase users (not musicians, not sound engineers, etc). From my point of view it is much easier to find help here than to call or write them. I do not trust these guys anymore.

Cheers!

Cubase Pro 11.0.30 here. I can attest to the OP’s issue: With count-in on, you cannot start record in the middle of a bar: the cursor will always jump back to the beginning of the bar. I fail to see why Cubase cannot have a count-in to a record-start position that is in the middle of a bar.

I’m not sure what the problem is.

You can achieve this by either using punch-in / punch-out points, or by properly setting up your pre-role.

Either way you can achieve what you’re trying to achieve.

Using pre-role method you’ll execute the recording by actually hitting the record button.

With punch-in method you’ll execute the recording by hitting the play button.

Now if you’re trying to use the “count in” function that’s a problem. I’m not sure why anybody would use “count in”.

Considering how long it’s been since the OP visited this thread, I’m assuming he learned how to use the program and didn’t come back to post his solution for other new users to benefit from.

Or maybe he went back to using Protools or Logic.

Personally, I use this macro.

Locators to Selection (for Recording)
Transport - Locators to Selection
Transport - Set Punch Points to Selection Range
Transport - Go to Left Locator
Transport - Nudge -1 Bar
Transport - Nudge -1 Bar
Transport - Set Left Locator to Project Cursor Position

I believe this happened to me too and support replicated it via screen sharing but there wasn’t a resolution. It’s good to see someone else was confused by this and it’s also good to see information about using punch points (which I haven’t done yet). It’s been a long time but I think it tripped me up on a project where there was one extra beat (rest) before the next section which meant all the remaining sections didn’t start at the beginning of bars and using cycle recording, I couldn’t get the cycle to be an even repetition. I’m probably wrong, I gave up on it and worked around it since then. Looking forward to trying the suggestions here! Thanks to those folks!