(bug?) Auditioning, or "play" tool doesn't work with headphones and monitors at the same time in CR

In Audio Connections, I got a monitor out and a Headphone out set up for Control Room. When working with either samples or midi, the audition “play” tool only works through my monitor out, but not the headphone out.

IIRC, when Control Room is enabled, audition would play through Control Room, or, through Main Out if Control Room is disabled, according to documentation found online on Steinberg.

Is this a bug? I have to use a workaround by creating a second monitor output that will be for my headphones, so I have to switch between A/B if I want to work in my headphones.

If I’m not mistaken, there is a preferences to use Phones as Monitor.

I’m not able to find such options. The only thing I can do, is ticking the “Use Phones Channel as Preview Channel” in Preferences under VST - Control Room, but that leaves the monitor out behind. And it’s honestly more time consuming than my first workaround to the issue.

Unless I’ve missed something, I remain clueless :stuck_out_tongue:


This is the preference I was in my mind.

Why it doesn’t work for you?

I want to audition any sample or midi track through both my monitors and headphones at the same time.

This setting doesn’t allow me to do that while using both outputs at the same time because the Preview Channel will be routed to the Phones Channel instead of the Monitor. Unless I ditch the Control Room where I use Sonarworks SoundID for my monitors and headphones individually to avoid switching profiles all the time, I can’t seem to find any other solution than to create an additional Monitor Out for my headphones, and switch between A/B.

I have edited the headline of this topic in case it will avoid any confusion. I apologize if it felt misleading to the issue I’m having.

This is usually done in the routing of your interface. On my interface I can assign the same outputsmultiple times. You i.e. have to assign output 1+2 to the physical outputs of your monitors and at the same time to the outputs of your headphones.
Then assign 1+2 as your main output in CR and voilá.

That I’m well aware of. My RME and MOTU devices are well capable of this. At the same time, I don’t have to do this, as disabling CR is more than enough.

As I have stated before, I merely want clarification whether this is a bug or not. If I can’t use a simple tool without an unseen problem like this, I have to sacrifice and use midi for SoundID everytime I switch between my monitors and my headphones, or create a second Monitor Out for my headphones and monitors, and switch between A/B in CR.

Both workarounds are, frankly put, too silly just to get things working as it should work, according to certain documentation. I’m using “play” tool frequently and I happen to switch between headphones and monitors for different purposes, that’s all there is to it. I don’t want to switch cal profiles in SoundID or Monitor Out’s in CR just to get one thing working through both at the same time when it’s just one tool that should at least play sound through Monitor Out and Phones at the same time.

Sorry for repeating myself by the way.:joy:

The Play tool will, I believe, only play on the Main Mix output, as defined in Audio Connection.

I know this already.

I suppose I have to quote steinberg themselfes.

“When auditioning with the Speaker tool or Audition icon, audio will be routed directly to the Control Room (Cubase Pro only) or to the main mix (the default output bus) if the Control Room is disabled.”

I’m reading this, as if Control Room is enabled, audition"play" should at least play audio through all my active outputs within CR. Unless this is a typo from them, I’m still questioning whether this is a tiny bug or not.