bug:Automation of Retrologue doesn't get mixed-down/frozen

Just when I was ready to do a mixdown of my new track including the new Retrologue I was shocked to find that I can’t record the automations I made on Filter cutoff, Filter, resonance, Filter Envelope, … just everything.
The automation on the effects works, but not on Retrologue. When played “live”, it all works, but not on Mixdown and also not when the instruments get freezed.

Now I have to try “realtime recording” in some way to get my track properly recorded or again replace the Retrologue with another synthesizer :frowning:

Steps to reproduce:

  • Create a track with Retrologue
  • Record automation for Filter Envelope Decay, Filter Cutoff and other parameters
  • Mixdown the whole track or freeze the instrument
  • the automation is not reflected in the result.

…using Cubase 6.5 on a 32Bit Windows system.

Using “realtime export” works, BUT sometimes my CPU is too slow (although an overclocked Quadcore with 4x 3,0GHz)… this won’t be a long-term solution and I hope only Retrologue is affected otherwise mixing down songs would be quite a huge PITA.
(Although there are graphic errors when cloning tracks with ALT-SHIFT-Drag, but that doesn’t really bother me once I got used to that)

This might also help:
The track was previously a Cubase 6.0 track, it has lots of NI-synths (3xMassive, 1xAbsynth, 1xKontakt, 1xBattery), Halion SE and one freeware Soundfont-Player.

I will also try to reproduce that on a “fresh” document maybe this night.

I have the same problem in Cubase 6.5 32 bits on windows 7 64 bits and on windows xp 32.
However, I get the automation to work in Cubase 5 on both systems…so an upgrade synth that only works fully in older Cubase versions…
Padshop seems to work fine though.

I compared that now to another synth like Prologue. That one works fine.
I also found out that you need to automate MANY attributes, not JUST cutoff or resonance, that may even still work.
In my track I had 6 automation tracks and only 2 of them were actually taken in account (filter/resonance), so the order of the automation tracks didn’t play a role. But maybe the controller IDs? I assume that filter and resonance have a lower id than envelope settings and stuff like that.

I have attached a zip with a CPR file.

You can compare for yourself: Does the frozen/mixed-down version of the Retrologue track sound the same as if played in realtime?

After all, if Retrologue works well in older versions of Cubase, it seems to be an actual Cubase problem still. I thought this was Retrologue-only. I hope there aren’t any further surprises when working with other synths.
retrologue_fail.zip (25.1 KB)

I actually got exactly the same bug, i’m on cubase 6.5 64 Bit. How can this still not be solved ??? This is one major bug. BUG CONFIRMED, DO SOMETHING !

Even Realtime Export didn’t fix my automation. Unfortunately this automation is essential for my track and all my hard work will be lost if i won’t be able to export all my automations. I’m now trying to play with buffer sizes and i read something about the dithering method causing automation fails. but i have actually no idea.

i’m really shocked. this is just something that shouldn’t happen ever to a professional program like cubase… :imp:

Strange, I’m on 6.51 64bit and I just exported a bunch of tracks separately (using the batch channel export) and the retrologue has all the filter automation… (I didn’t use automation on the resonance though)

Never noticed it because I mostly use MIDI to control parameter, but confirmed here too.
I’ve set up a loop with a few automated tracks:

OCS1 Octave
OCS1 Coarse
OCS1 Waveform
Filter Cutoff
Filter Distortion
Filter Resonance

Both OSC1 waveform and OSC1 Octave where not included in the export.
In the realtime export they are, indeed.