Bug: changing color of rests does not include dot

Hi there,

I have a staff for which i’m trying to make rests invisible as it’s more of a ‘graphic notation’ staff. I’ve followed the suggestion of https://japan.steinberg.net/forums/viewtopic.php?t=105496&p=579280 and made the opacity of my rests set to 0% and discovered that in any dotted rest, the dot does not follow the opacity of the rest itself. I can’t seem to make that dotted rest go away since Dorico automatically corrects, say, three eighth note rests to mean the same thing as a dotted quarter at the end of the 12/8 bar.

Attached is an image exemplifying the issue.
Screen Shot 2017-04-16 at 13.02.34 .png

If you open Notation Options (command-shift N on mac), and select Rests from the pull-down menu, there is an option to disallow dotted rests. Does that work for you?

It’s a workaround for the time being; in the future it may be possible to have a more robust Hide option, instead of turning opacity to zero.

Force Duration (shortcut O) will make Dorico accept i.e. three eighth-note rests, if you input them manually (with the input rest button activated). You cold also try Edit - Remove Rests to rid of the rests without the color-opacity show - although this might shorten the total length of the bar, which you might not want.

Can you not use the Edit > Remove Rests command to remove the rests on this staff instead of changing their colour?

Still, the dots ought to change color when you change the note or rest.

Jesper

I agree… It also would be useful to be able to set (hide) the number of prolongation dots for each note of a chord, individually (yes, there are situations in which this would be needed!)

It’s not straightforward to provide either of these options – i.e. hiding a rhythm dot or changing its colour – because drawn rhythm dots do not correspond one-to-one to the notes shown in cases where there are chords with sufficiently closely positioned notes that to show all of the dots would result in the stack of dots extending too far beyond the top and bottom notes of the chord.

As suggested in my earlier reply in this thread, instead of hiding the rhythm dot, use the undotted duration and use Remove Rests to remove the unwanted rest.

Thank you Daniel for the suggestion. I have tried that, also adding fake dots to the desired notes of the chord. The problem is that I need to add ties, and the rests does not allow to insert ties…

You should find that if you select the first note, then Cmd/Ctrl select the second note, you can then hit T to tie them together, regardless of any rests in between.

Oh, thanks, that helps a lot!