(bug) Chorus and StudioChorus use the wrong default waveform shape

Like the Rotary bug I reported, this one has also been around for a while.

Headphones recommended.

  1. Open a new project, set it to 120 BPM.
  2. Create a stereo audio track.
  3. Use “TestGenerator” as an insert effect. The default settings are fine.
  4. Use “Chorus” as an insert effect.
  5. Set the Mix knob to 100%, Spatial to 100, and the Rate knob to 1/4
  6. Now try changing the waveform shape to sine. The sound doesn’t change.
  7. Change it back to triangle. Now the sound changed, even though that’s the default setting.

So, the Chorus effect has two wave forms:

-The default is supposed to be triangle. It has a “jumpy” behavior.
-The other option is sine, which creates much smoother modulation.

But while the waveform shape switch is set to triangle by default, it actually sounds like a sine. You have to click this switch twice to actually get a triangle, which is the intended default value.

Confirmed here. The sound changes only when switching between waveforms. The only workaround is to switch the waveforms and then save it as default preset.