BUG: Cubase 6 and latency

so, it appears that I can work on an project and record guitar fine using Guitar Rig 4 when I first open Cubase, but if I close out the project, shut down my machine and open it the next day, I have a terrible latency problem with a file that worked fine just the day before.

I know it’s not the input, because that plays back instantaneously. It’s only when I am in monitor mode, and listening back to Guitar rig. I can literally open a new file, activate it, add Guitar Rig and it works perfectly… go back to yesterday’s project and there’s easily a quarter second latency.

any hacks or ways to get past this would be greatly appreciated. I’m working on projects right now and it’s becoming a problem. This worked fine in Cubse 5

and I can’t use 64 bit because half of my plugins aren’t suppored.

Mac Pro 12 core
32 gigs RAM
Cubase 6.0.2 (32 bit)
Saffire Pro 24

I have a similar issue frequently. I am not sure whether it is a Cubase issue or an ASIO driver issue, though.

What helps here in most cases is to change the ASIO driver’s buffer size. This resets the ASIO driver and the latency problem is gone.


I’ve reset the buffer size over and over again… I can also confirm that this NEVER happened with Cubase 5. Definitely only Cubase 6.

Upgrades disable Steinberg Audio Power in Device Setup. Have you checked to see if this is the problem?

I don’t have anything under device setup called Audio Power? All my ASIO input and output do appear to point to my Saffire, but again, there is no latency on a new file-only when I open a file I’ve been working on, so I feel fairly certain it’s a bug… have you ever had this happen? Seems very strange to me.


Yes, you do. Devices → Device Setup → VST Audio System. Look in the bottom half. Steinberg Audio Power needs to be ticked. It might not solve all your problems but they will be worse without it.

well it’s definitely not there. They must have changed something… see screenshot attached.

Sorry. You’re on a Mac, aren’t you. Ignore all this.

ok, so is anyone else seeing this? It’s driving me batty and it’s not happening in Cubase 5.