BUG: Cubase 9.5 Tempo Detection only works properly at 44.1k

Is it possible this is also a problem with Process Tempo?
I run 48k projects, and could not get this simple thing to work and give a correct tempo.

EDIT: I found this out - that Process Tempo is broken completely and posted separate thread on this.

Are there any updates on the issue?
I can still reproduce this with the latest 9.5. release (9.5.50). And it looks like the bug exists in Cubase 10, too (see https://www.steinberg.net/forums/viewtopic.php?f=286&t=157039&p=842902&hilit=tempo+detection#p842902).

On my system with C9.5.50 I can’t reproduce this. No crash at 48k.

Have you tried to “fiddle” a bit with the “warp markers” after you did the analysis? For me, with 9.5.50, this works fine for 44.1kHz. On 48 kHz sampling rate, the markers tend to jump and overlay each other as soon as you try to move them. And after a few attempts, Cubase freezes.
I use a 4.20 minute long audio track - perhaps it is a matter of the size of the track, too?

There are other odd things to observe:

  • Analysis is way faster on 44.1 kHz as it is on 48 kHz (I guess around factor 3 or 4)
  • On 48 kHz, it seems to be less accurate (I get some positions in the song with wrong detection that raises the need to use the warp markers)
  • The “smooth tempo” button is always deactivated for unknown reason

I followed the repro I spelled out above: Start Cubase in Cubase Safe Start mode to rule out corrupt pref problems. (You can also save a preset of your prefs)

This thread is about the one specific bug, and nothing else. Please, just start another thread for anything else.

Repro:
Set project and audio files to 48khz (or any value more than 44.1k)
do tempo detection
leave tempo detection panel active and reanalysis arrows where they are.
with the warp tool, move the grid.
Unexpected result follows, and Cubase becomes unstable.

I followed exactly the steps you describe in your last post, and I can still reproduce it.
The warp grid “markers” jump unexpectetly, and after a few moves, Cubase freezes.

Since you’re getting that result and I’m not, maybe verify the version you’re running? and rule out corrupt prefs by using Cubase Safe Start Mode… The audio file I used was about 5 minutes long.

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Hi.
I used Safe Start Mode in the last tests already (disabled my preferences, middle Button in the dialogue that pops up on holding CTRL+ALT+SHIFT on startup).

In the “About Cubase” popup, it says it is Version 9.5.50 Build 345 - Built on Feb 2 2019.

I’m working with one track of MIDI and I get this bug. As others have said, when you change to 44.1k it works. (Checked in Cubase 10.0.15 and the latest version of 9.5)

The history shows two events each time I attempt to move a marker: ‘Warp Tempo’ and ‘Iterative Beat Correction’. It seems like the second stage is bugged as the bar/beat line shows at the intended position when you undo.

Studio One and Harrison Mix Bus under evaluation in my studio.

I won’t be upgrading from Cubase 9.5.

Will post results here.

In short, it’s been 16 months since I first raised this issue. Bottom line, unless you are only using 44.1 Cubase is unable to perform tempo map functions which makes it unsuitable and unviable for professional use.

I hope the people who continue to see this problem report it in a support ticket. I can’t reproduce it on my system. I reported, and it was fixed- but not for every case, apparently.

I can confirm the bug still exists with 9.5.50.

Have tried to log a support ticket but have no option…

See https://www.steinberg.net/forums/viewtopic.php?f=253&t=159627

In desperation to finish an existing Cubase project I’ve upgraded to Cubase 10.

In doing so, I uninstalled all Steinberg software, tracked down all Steinberg folders and removed them and did a completely fresh install of 10.0.20.

Confirming: the bug still exists in version 10.

Reported here : https://www.steinberg.net/forums/viewtopic.php?f=286&t=159692

Hi,

I tested this on Mac and Windows in Cubase 10.0.20 and Cubase 9.5.50. Both works as expected. I can Warp the tempo manually. No crash, no freeze.

Hi Martin, thanks heaps for testing. Can you confirm a couple of things?

Likewise, I can manually warp the tempo by using the warp tool in the tempo track.

My crash occurs when the Detect Tempo window is still open after using the Analyse function. My workflow (used to be) to analyse, then working through the event, adjusting manually for anything that wasn’t correctly detected, with the detect / analyse function still open and working to adjust points to the right of my manual corrections. This is the scenario that crashes.

Do you also have the detect window open after having first done the analyse in say a 96k project?

Many thanks.
Brendan

Here is a screen capture of the crash.

(Note the child windows and menu drop downs don’t show). At the end the Cubase is frozen. Note the Detect Tempo child window is open (but not shown).

https://youtu.be/Dc5Yr2aSwww

Hi,

Now I can reproduce it. Btw, it’s Windows only. Reported to Steinberg CAN-22700.

Many thanks Martin. Much appreciated.

Hi,

A workaround is:

  1. Once the Tempo Detection is done, click to the Object Selection tool (or any other tool).
  2. End the tempo detection session by clicking to Continue.
  3. Select the Time Warp tool again and adapt the map.

Or simple just close the Tempo Detection window. :slight_smile:

Yes that’s the only way… which is what I’ve been doing when pressed. However, inevitably the detection is wrong anyway (especially for 96k projects), so you end up having to make so many manual adjustments that it’s easier to build the tempo map from scratch. For projects that include time signature changes (for some reason I get too many of those!), there’s the added hassle of having to delete a whole bunch of tempo points too. Bottom line is that the tool is broken.

Not sure if it’s related, but another issue that got me last week was hit point detection in a midi track. The midi was recorded in to a 96k project without click. I needed to build a tempo map from the midi event and tried the detect process. It got it badly wrong per bug, but then I dropped the project back to 44.1 (and in trying to find a solution also exported the midi and imported into a fresh 44.1 project), however the hit point markers in the midi file persisted making it impossible to quantise or do any tempo detection. Ended up getting the musician to re-record into a 44.1 project.

Overall this whole area of tempo / tempo track / hitpoints seems to be going down hill in Cubase.