Bug - Default Presets for Effects Not Being Recalled After Dragging from Browser (No Change in 10.0.10)

EDIT: Dec 3, 2018
The bug [along with an important missing detail] has been confirmed by medwaystudios. The steps below have been updated.

If your VST effect plugin has a default preset you created, this preset is ignored after dragging and dropping the effect from the new browser. This only happens with effects (default settings for instruments that are dragged and dropped work), and only happens when dragging and dropping effects from the browser. If you insert them the old way, the default preset works as expected.

I’m using Cubase 10 on Windows 10. To reproduce:

  1. Open (or create) a project
  2. Open a VST effect (how doesn’t matter yet)
  3. Change some settings, and “Save as Default Preset”
  4. Now, open the right-hand browser, locate that VST effect and drag and drop it into the arrange or console views to add it to an existing track or to create a new FX track (any combination has the same result)

Result: The new default preset is not recalled.

Expected Result: The new default preset is recalled.

As mentioned, if you add the effect “the old way” the default preset gets recalled as expected. If you repeat the same process with instruments, the default preset is recalled.

Anyone able to confirm this one? Still not sure if it’s a bug or a support issue. Should only take a minute to test and reproduce.

Working here except for when I drag a plugin from the right hand media section .

That’s exactly it. It works as long as you don’t drag and drop from the browser. I’m updating the thread title and steps. Thanks for checking and replying!

This is too bad as I love time saving default presets and the new time saving drag n drop with pictures in the right browser. Wish they worked together.
Martin will this be fixed?

Just confirmed this is still an issue in 10.0.10.

Didn’t see it on the release notes, but figured I’d try anyway.

Note: there’s no way it’s intended that Default Presets don’t work in the browser (and they do for instruments) so this is either a bug, a gap in the initial requirements, so some acknowledgment of the issue from Steinberg would be welcome. I even input a support request for this a few weeks ago and haven’t heard back on that.


Sloppy and careless coding once again.

Just a small update on this one: Eric at Steinberg support has reproduced the bug and has forwarded this to the development team. Not sure when we’ll see the resolution, but it’s been officially acknowledged and should now be “on the list” so to speak. Took a while for them to reply, but thanks to Steinberg Support for eventually getting back and working with me to reproduce and confirm the issue on their side!