[Bug] Home/End keys behave erratically

This is a new problem surfacing in Cubase 6 that was not in 5.5.

When no regions are selected, the Home and End shortcut keys work fine. Home goes to the first track of the sequence (Navigate - Top), and End goes to the last track of the sequence (Navigate - Bottom).

However, if any region is selected, pressing Home and End randomly cycles the selection through the regions in the project. It’s very frustrating.

(Cubase 6 32-bit mode on OSX 10.6.6 - Mac Pro 8-core)

Hello Orchetect,

yes this is indeed working a bit strange. We will have a look. (28141)

Cheers,

Chris

Might it have something to do with this:

http://www.steinberg.net/forum/viewtopic.php?f=19&t=3323

To add a repro and a workaround:–>

The commands “Navigate - Top” and “Navigate - Bottom” are working correctly in Cubase 5:
Open Cubase 5.5.2

  1. Create 4 Audio Tracks
  2. Draw in 3 events on each track
  3. Select the first event on the first track
    4 Press “End” on the QWERTY board (pos1 on the QWERTZ board)
  4. Press “Home” on the QWERTY board (ende on the QWERTZ board)
    Note: The commands “Navigate - Top” and “Navigate - Bottom” work correctly

The commands “Navigate - Top” and “Navigate - Bottom” are not working correctly in Cubase 6:
Open Cubase 6

  1. Create 4 Audio Tracks
  2. Draw in 3 events on each track
  3. Select the first event on the first track
    4 Press “End” on the QWERTY board (pos1 on the QWERTZ board)
  4. Press “Home” on the QWERTY board (ende on the QWERTZ board)
    Note: The commands “Navigate - Top” and “Navigate - Bottom” do not work correctly if there is an event selected. The problem will persist if you link the commands to different keys with the “File–> Key Commands” function.

Workaround:

Macro (Home):
Edit - Select None
Navigate - Top

Macro (End):
Edit - Select None
Navigate - Bottom

Gr,
JHP