Bug in linked groups & VCA faders = all tracks record arm

What frustrates me most with both Link Group settings and with VCA faders is that once I assign any set of tracks to a group (either linked tracks or VCA Fader), when I select one track from the group, all assigned tracks now record arm automatically. I’m starting to think this is a bug because of some odd behavior that I will explain below.

Steps: Note this happens with any combination of tracks but its easy to see using a Halion instrument track.

  1. Create a Halion as an Instrument (or rack) track
  2. Assign sounds to as many midi channels as you want inside Halion
  3. Create midi tracks for the sounds you’ve assigned
  4. Go into the mixer and select a few of the midi tracks
  5. in the mixer choose “link selected channels”
  6. Select one of the midi channels in the group

You’ll notice that - even though you do not have selection checked as a link option - all midi tracks assigned to this group record arm. To me this is a bug because only selected tracks should record arm, correct? Plus this serves no functional purpose for if I wanted a “layered instrument” I would have assigned the sounds in Halion to all be played from one midi channel.

But to make it even stranger, do the following

  1. Select a midi track in your linked group - result is all tracks in the group are record armed
  2. Select a different midi track in your linked group - result is that only this track is record armed!

This to me proves the bug, as the same functionality (selecting a track in a linked group) produces two different results depending on the order you select them. If I select “track 2” of the group first, the whole group record arms. If I select “track 1” and THEN “track 2” only “track 2” is record armed.

PLEASE fix this issue. Again it exists with both linked groups as well as VCA faders. As it stands this behavior bug makes linked groups and VCA faders to frustrating to use, and I’ve read many threads here where others are experiencing the same frustrations.

Thank you for the consideration. I still think cubase is the best DAW on the market and hopefully small issues like these can be addressed in Cubase 8. (in fact if this is fixed in an update to 8.5 I’ll pay to upgrade that same day!)