Bug in master section - playback processing slots

PROBLEM:

  1. Load Voxengo Curve into the 1st slot of playback processing (use it as a spectrum analyzer, but don’t EQ)
  2. Load DMG Equilibrium into the 2nd slot of playback processing (I’m using the VST3 version)
  3. Cut high frequencies in DMG Equilibrium

Notice the spectrum analyzer display of Curve now shows less high frequencies? Curve is 1st in the chain - before Equilibrium. This should not happen.

WORKAROUND:
4) Drag Curve down so the two plugins change slots and Equilibrium is 1st
5) Drag Curve back up so they change positions again and Curve is 1st
6) The problem is fixed by steps #4 and #5

Interesting that just dragging back and forth seems to fix it… Not sure what’s up…

When the plugins change slots, the order of the chain is changed, and so Curve now shows the effect of Equilibrium - why would you expect otherwise? How can the order of the plugins be visibly defined other than by their order in the slots?

Paul

Maybe I didn’t explain quite well enough… When Curve is first in the chain, the meter should not reflect any changes done in Equilibrium (second in the chain) - and yet, IT DOES.

The workaround is weird… just by swapping the order, and swapping back, it fixes the problem, and curve reflects the correct spectrum (NOT reflecting the Equilibrium EQ.

Sounds like maybe the same thing you found swapping the order in my UV22 thread? Swapping the order and swapping back appears to fix, or does fix, the problem?
https://www.steinberg.net/forums/viewtopic.php?t=145297

Yep… that’s why I thought of the idea to swap the plug-ins, and sure enough, it did fix it!

Just wondered, what happens to the level in those two plugins when you reduce the Master Section faders?

Sounds like a glitch in the matrix.

I can’t reproduce, but I use another EQ than the DMG Equilibrium. Can you reproduce eg. with Steinberg Studio EQ?
Please reset the Master Section before, to start from clean.
Please also verify in the WaveLab about box that 9.5.40 is really the installed version.

Hi …

I have these plugs and have also been unable to reproduce your issue. Are you using the latest version of the DMG plug (not that this should make any difference unless perhaps you have the EQ set to use a mid or side configuration internally … I tried both stereo/mid in the DMG by the way).

There is still something strange going on with the mastering slots. Some VST-3/2 plugins seem to not be effecting the audio being played. There are a few plugins (I will get a list together and post) that since version 9.5.45 simply do nothing when the faders or knobs are turned. This is since the upgrade. It is almost like they are permanently bypassed. Anyone else notice this? Also the ACON plug ins show up in all my other DAWs and work fine but in WL they all show up as “DEMOS”. Not sure what is going on.

I am definitely using 9.5.40. I was easily able to reproduce the problem when I tried again 1st thing just now - with the included Voxengo Curve plugins that come with Wavelab.

  1. Load Voxengo curve into 2nd slot, and drag the right point all the way down so the sound is super dark with little high frequencies.
  2. Load another Voxengo curve into the 1st slot and leave flat
  3. Now play back some audio and look at the Voxengo in the 1st slot… it shows the frequencies as too dark.
  4. Now while looking at voxengo Curve in the 1st slot, click “bypass” on the other instance of Voxengo (in the 2nd slot)
  5. Suddenly the curve goes up in the 1st instance. This should not happen…

I can reproduce this every single time.

Thanks,
Todd

Hi Todd, I tried your procedure but, sorry, I can’t get a repro. The Curve EQ response is as expected here. Just wondering. What audio are you using for this test? What is the precise version number (including build number) of the Wavelab you are using?

Wavelab Pro 9.5.40 (build 180) - 64-bit. Session optimized for CPU:19

I’ve been trying many different ways to see what causes it… try this:

  1. Load any WAV file into the audio editor (just to simplify the process). The file in my case is 44.1khz, 16-bit.
  2. Load Voxengo Curve into the 2nd playback slot (leave the 1st one empty for now).
  3. Drag the dot on the right side down so the high frequencies are reduced.
  4. Load another instance of Voxengo Curve into the 1st playback slot. Apply no EQ - leave the line straight with no points.
  5. Drag plugins so you can see both Voxengo instances at once. Notice even though the 1st one has no EQ applied, and the 2nd one does, the displays are the same…
  6. Now bypass the 2nd instance (the one with the EQ applied). The display in the FIRST instance gets brighter - even though it’s the 2nd one that was bypassed. Now re-enable the 2nd instance… the display in the FIRST instance gets darker! I can click back and forth… The display in the first instance is not correct… it’s reflecting audio changes in the second plugin.

When using these exact steps, I can reproduce this problem every single time.

Thanks,
Todd

Same here. And I get the problem if I do the same thing with Curve EQ in the Final Effects/Dithering section.

Only if inserted in that order though.

I can reproduce now with the exact steps you mention. The plugins are inserted in reversed order. This in the dither and playback section, not in the effect section (where I originally tried).

Hey PG,

I know you have a lot happening right now, but do you have any estimate when this one will be fixed? 9.5.x? V10?

Thanks,
Todd

It is fixed for upcoming 9.5.50 (march)

Cool - thanks PG!