bug involving different sample rates and unable to PLAY

got a repeatable, every-time bug going on here this morning.

WL 10.30
mac Mojave


  • system set to 44.1
  • open 96k file in WL. don’t touch anything. convert to 44.1
  • play doesn’t work, either by spacebar or transport button

need to quite wavelab and reopen to be able to play files again

anyone else experiencing this?

I can’t say I’ve never tried doing this. I think more info is needed about HOW you “convert to 44.1”

And also, it would be worth trying with more than one interface because some interfaces seem better than others in WaveLab dealing with sudden sample rate changes of the source file/project.

i convert the SR with the RESAMPLE tool in the process tab.

i haven’t tried reproducing the bug going from other rates besides 96>44 but i’ve sample rate converted plenty of times in years of using wavelab and haven’t experienced this bug until 10.30

seems like a bug because why would wavelab make you quit and relaunch in order to simply play a file that had been converted.

also, note, i’m not playing the file while it’s still 96… i haven’t freaked out my interfaces by trying to play a 96k file while the system is set to 44…i simply open the file then immediately convert it to 44 … which is when playing doesn’t work. hitting space bar or clicking the transport control. nothing happens.

i’ve only had weirdness and convertor freak-out (see my other posts) when i try to PLAY a file that’s a different rate than my system is set to, but from my experience simply having a file open of a different rate is fine… the system doesn’t seem to know it’s a different rate until it tries to play it.

it may be something simple for you (or others) to test… have your system and convertors set to 44.1. open a 96k file in wavelab, convert it with RESAMPLE to 44.1 and then hit PLAY and see if it plays.

I see, it just wasn’t clear if you were using the batch converter, or rendering a new file at a new sample rate.

I think those details are important to know. I don’t have an answer but this provides more clarity on what you’re doing.

If my interface that WaveLab is using is also the master clock, it changes sample rates without any issue, and very little delay if I try to play the file. If I don’t play the new file, nothing happens.

If my interface that WaveLab is using is being clocked by something fixed to another sample rate, the file simply doesn’t play, but nothing freaks out or crashes.


Is this with built-in audio device or ?

Because with old RME Fireface 800 and OSX 10.13.6 High Sierra
and WL 10.30 and I can’t confirm it works here.

regards S-EH