[BUG] Midi editors crash when using infoline in 6.5

So this has been reported a couple of times, where usually the fix is to trash preferences. But we managed to track it down, so I figured it’d be better to create a new topic as all old ones are now called [SOLVED], which they aren’t :wink:

Anyway, the repro is very simple.
-Create new project
-Create midi track
-Create midi event
-Go into key editor or drum editor
-Draw a few notes
-Enable the infoline (most top left button in the editor)
-click some notes and their values in the infoline
-CRASH.

similar reports:
http://steinberg.net/forum/viewtopic.php?f=19&t=19899
http://steinberg.net/forum/viewtopic.php?f=19&t=20486&p=130207#p130207 (first post on 15th of March)
http://steinberg.net/forum/viewtopic.php?f=19&t=19794&p=125539#p125539

Trashing preferences fixes this because it disables the infoline, but as soon as you enable it again, the crash is back. I hope everyone can reproduce :wink:

I edit info on the infoline all the time and never have a crash. I edit such things as velocity, note expression etc, quite successfully.

Hello,

not crash here too. I’m using Edit Info all the time.

Best,

Mmh, shame, I was hoping it would be easier to trace. I’m using Cubase artist 6.5, on w7 64 bit. Iirc other reports used Cubase 6.5 on both windows and mac.
It happens in every project, I’ll try using a different template.

Available for me too. I use both windows 7 under 32 and 64 bit, and in both I get crashes in MIDI editors if I check Info line. Otherwise it works perfectly. My external soundcard is UA-4FX, but in 32 bit I use SW1000XG as well.
Tried new 6.5.1, got the same problem. I will soon install it on my MacBookPro as well and see if…


Sorry, still using 6.0.6 on Mac, would not try to crash my other system as well…

Same error with me. Been working on it all day (half of weekend is gone now… thanks Steinberg). My error can be reproduced exactly like is said earlier in thread. Configuration Windows 7 64bit, upgraded Cubase Elements to Cubase Artist 6.5.

Hey Robert, Steinberg released a fix for this problem. Download patch 6.5.2 from the Cubase Artist page on www.steinberg.net and install that. It fixed the problem for everyone as far as I know :slight_smile: