Bug? MIDI notes outside event get included in bounce/glue

If a MIDI event has notes that lie outside the event boundaries, and that event is glued to an overlapping MIDI event, then the notes that should have been outside are now contained inside the new event and will play back.

There is also an error in the way in which overlapping MIDI events are displayed in the sequencer.
In the screen shot, the red event has been resized so that only its first 3 notes are within its boundaries.
Then on the lane underneath, an empty event (the green one) is created that overlaps it.
As you can see, the “overview” on the main MIDI track is wrong - it shows the excluded notes, even though they are outside the red event and do not play back.

If the green event does not overlap the red, then the overview is displayed is expected (see right side of the screen shot)

In all cases, playback sounds normal - only the first 3 notes are heard.


if you now attempt to glue together or MIDI->Bounce MIDI the red and green events, then the resultant new event will be just like the erroneous overview in the screen shot. It will contain the “excluded” notes, AND they will now be audible!

This is a disaster when I am glueing lots of parts together that have been previously resized. I end up with doubled MIDI notes all over the place. To add insult to injury, the delete doubles command does not work properly due to internal rounding errors (this is confirmed by SB)

I come up against this problem many, many times a day. A very frustrating workflow and inspiration - killer.
I compose for film and TV (professionally now for 8 years) and work with lots of MIDI.

If there was a command to “delete MIDI notes outside event boundaries” that would help, but I don’t think such a thing exists (or does it?) Maybe it’s possible to write a macro to do this but I have had no luck.


Maybe it’s me, but I don’t understand what you are trying to achieve and how you go about achieving it. Which events are you talking about and what should not be included?

BTW, assuming a certain behaviour is a bug doesn’t really help anyone, especially since this is the Cubase 6 forum, where the bugs can be expected to be well known.

Have you even looked at the screen shot?

What I am trying to achieve is this:

  1. When I glue together MIDI events, I do not want notes & MIDI messages that were outside the event boundaries to appear in the result. That’s why I excluded them from the event in the first place! They were (correctly) not audible during playback, so they should not be included in the resulting MIDI event.

  2. I want the MIDI track visual display to match what is heard. Currently it does not, IF there are overlapping events.

How can I get rid of notes that are OUTSIDE event boundaries? (apart from manual editing - impractical when hundreds of MIDI events are involved)

You ask “which events?” The events in the screen shot are a simple repro. In reality, I have VST drum machines, samplers, and instruments and their corresponding MIDI tracks. On those tracks are many, many events. Inside those events are MIDI notes and controller messages, some inside the event boundaries, some outside the boundaries. Occasionally I want to join events together. When I glue or bounce them, I end up with lots of unwanted or doubled notes in the result because the glue & bounce functions included notes they should not have included (ie the ones outside the boundaries).

The short version of my question is: is there an easy way to get rid of MIDI data outside of event boundaries? If so, I can incorporate that into my workflow as a workaround.

Maybe it’s because I looked at the screenshot that I don’t get it, because there are two red and two green events in lanes and it’s unclear what should be out and what should be in, especially since there are three green ones with no data.

Anyway, there should be a global MIDI setting that prevents this from happening IIRC. I hardly use lanes with MIDI, so I can’t tell how it’s called by heart… As an aside, I think cutting and deleting the unwanted parts instead of resizing them, should prevent the problem altogether.

Here’s the issue in “repro” form. The OP has more info than needed and it didn’t help to illustrate the issue. (imo)

  1. Create a midi track and a part on that track.
  2. Insert some midi notes
  3. Shorten the part so at least one of the notes is outside the shortened part boundaries
  • Now create a second empty part on the same track and place it so it overlaps the first.

  • The notes that are outside the bounds of the first part are now shown in the second, but do not sound. (Note also, they keep the color of the part they come from, or, if both parts are the same color these notes are a different shade)

In Cubase 6.0.7 if I midi bounce or glue the two parts, the outside-the-bounds notes are gone, unlike what you are seeing.

(I don’t have 6.5 installed, but the behavior is the same in 7.5.10)

Is this not what you are seeing? If not, can you write a step by step repro?

Thanks for helping clarify my ramblings Steve!

It seems that the glue/bounce “issue” does not want to reveal itself in the context of my small repro project.
Strange, since I have several “live” projects where the issue manifests very predictably.
I have also experienced it at various times using versions 5, 6.0 and 6.55.

Maybe there’s a setting I’m missing, but I can’t find anything in prefs.
Could there be a project-specific (or session-specific) setting which is causing it?

I’ll post back when I get a proper repro going for the glue/bounce thing.

Well, that was quick. Got the bugger!
The second event needs to start before the first, for the extra notes to be included.


  1. Create a MIDI track and draw an event on that track.
  2. Draw some notes inside the event.
  3. Shorten the event by dragging its right-hand edge leftwards, so that some notes now fall outside the boundaries of the event.
  4. Draw a second, blank MIDI event on the MIDI lane underneath the first. The second event needs to begin before the start of the first event, and continue for some time after the end of the first event.
  5. Glue the parts together or do MIDI->Bounce MIDI
  6. The resultant event now contains the trailing notes from the first event.

This can be seen in the new screen shot:

The red event is created with several notes inside (bar 10). It is copied and resized and an empty (green) event is drawn underneath (bar 33). Note the display error on the overview line. After glueing, the result is the blue event (at bar 49) which now contains the trailing notes previously omitted.

Points to note:

  • The events do not have to be on different lanes, the issue will also occur when the events are all on the same lane, or if lanes display is turned off.
  • Only the “trailing” notes are included (ie the ones after the right boundary). If there are any notes to the left of the event, these are not included even if there is an overlap.

Hm. This might be intended behavior.

If there was an easy way to delete the notes outside an event, that would be a helpful workaround.
Any ideas how to do that? (apart from manually cutting)

Additionally, the first “issue” of the incorrect display seems to depend on which MIDI event you last moved with the mouse!
If I move the first event vertically onto lane 3, the display corrects itself (ie the extra notes are not visible)
Then if I move it back to its original position (lane 1), the display is still correct.
But if I move the empty event to another lane (vertically), the display issue comes back again.

“Intended behaviour” - definitely not!

Interesting reading :slight_smile: (I had quite a job following it all :blush: :wink: )
I can now confirm (thanks to the last two recipes) when glueing, but, even in the 2nd recipe, it seems to be working ok here when “Merge MIDI in Loop”.

Thanks for persevering!
I was actually using “Bounce MIDI” on the MIDI menu, not “Merge MIDI In Loop”.
I have not tried that command, and it may be a good workaround, so I’ll check it out. Thanks for the info!

I can happily confirm that the command “Merge MIDI in Loop” is unaffected by the issue.

It’s not quite as quick and convenient to use as “glue” or “Bounce MIDI” (a few more steps are needed) but on balance, this is less painful than manually deleting unwanted notes/controller messages.

Incredible that 3 years later the bug is still there. I was going nuts since I give cubase lessons and I couldn’t clarify this behaviour to my student. Had an awkward moment there! Today exist the bound midi command. Anyway we all know the bug is there