BUG: MIDI volumes not remembered...

Don’t seem to be able to get help on the cu5 forum so I’ll try here.

Cubase 5.5.2 doesn’t seem to send volume messages to midi tracks when you first open a song, so you have to go to each track and re tweak each volume.

Is there any way other than automation which will make cubase send the volume messages properly. In theory Cubase should ‘chase’ these levels anyway, but is doesn’t which is annoying.

Is this the same in cubase 6?

What’s the workaround

I’m not sure what exactly you are doing, that isn’t working, but, here at least (Mac, and in Cubase 5 too), even if I don’t bother setting up any automation, if I set a MIDI track’s volume fader and/or panpot, it is indeed saved (and recalled) with the Project.

C6 has “Filter MIDI Messages” in the List Editor, so if you use CC’s they can be hidden from view.

I have never been able to figure our why Cubase 5/6 does not send Volume MIDI levels on startup. I’m used to that from my Logic days.

Volumes, Pans etc must be sent from within the MIDI part itself.

If they have to be sent from the MIDI part, what’s the point in having a volume control in the inspector?

Just to clarify, what I am trying to do is to set the volume of a midi track by moving the volume slider in the inspector (I assume that might be what it’s for). This sets the volume of the track, but as soon as the project is saved and re-opened, although the inspector volume slider is set, it doesn’t send out the volume message, so the volume of the track being played is wrong… Unbelievable…

MIDI Control Changes from the Inspector were ditched as of SX1.

+1 all cubase’s installed here save all volume and cc controllers as per project with no issue, have a look in the manual to see if there is a setting as from default .it should be saving and recalling all your controller values as stated

john

Well I’ve just loaded a song recorded in 5.1 and the inspector shows a volume of 54 for my MIDI cowbell track, but the cowbell is playing loud at 100. As soon as I click the volume control on the inspector, the volume resets itself to the 54 that it should be. This indicates that the volume set on the inspector is not being sent when i load the project up…

Either way, surely the chase events should pick this up. I don’t want to have to add automation for every sing track…

Any ideas anyone?

Deprecated function.

So what’s the point in having the volume slider in the inspector? These projects load fine in 5.1 so it can’t just be a ‘ditched’ function. There must be a setting i’m missing…

There is no point and Steinberg should hop to it and give access to a MIDI only mixer for the drum map only and rid the program completely of any front-end MIDI functions.

This would simplify the mixer and put all the “audio” functions where they belong, at the tail end of the process.

Hi. Mister ‘filterfreak’ are you saying that your system does remember midi volume settings made in the inspector?

If so, does it do it in 5.5.2? Are you on windows or mac? I don’t buy that the inspector just doesn’t work anymore as 5.1 does it fine. It’s more that cubase doesn’t send all the inspector values when it first loads a project. I’m fairly sure this is bug as 5.1 certainly does send all the volumes…

I’m looking at the volume automation and it has a blue line at vol=54. There are no ‘red dots’ but surely cubase should still send out the volume when the project loads. Even if I click the r button to enable automation it never actually sends the volume out unless i put in a red dot edit point.

Will this be sorted in 5.5.3?

Dear brains, it seems that filterfreak and vic_france are indeed able to set volumes in the inspector as for them to be recalled on loading the project, so it must be a setup thing. As a wise and noble chap do you know any settings for automation which would make cubase ‘chase’ volumes properly?

Personally I use MIDI program changes, coarse volumes, pans etc from the MIDI part only.

With cubase 6 you can now filter messages according to type so it is not necessary to use the inspector for midi related functions.

The only problem is notes always take precedence over commands.

(I’ve been playing around with various Preference settings etc., trying to get it not to work… so far without “success” :stuck_out_tongue: )
From what you write, it certainly looks like it should be working… especially if, as you say, it was fine in Cubase. 5.1.
Have you tried opening, in 5.5.2, a Project that you had created in 5.1?

Yes this is exactly what i’ve done. Made project in 5.1 and opened it in 5.5.2… I noticed that you are running on mac, so maybe this is a windows xp bug only…

O.K. This is definitely a BUG!!! I’ve just checked and all of the pans have been sent properly, but NONE of the volumes…

Steinberg please fix in 5.5.3

Ever since Steinberg embarked on writing apps for non-atari systems it has been in their minds to dispense with MIDI bar support of the standard as an extension to VSTXML for MIDI.

If anything I will argue for deprecation of MIDI functions for everything bar parts, and in the interim use midi only as a supplement to program automation with the eventual result that it will only be used in the drum editor as a legacy application.

Don’t think that’s a good solution. The inspector is a great way of quickly selecting a volume and pan and is industry standard. The volume and pan should follow any automation, but if a project is freshly loaded, cubase should send the midi data that the inspector shows. Having to set automation for each track is a pain in the a.

This is just broken software. It’s perfectly simple to fix it, but Steinberg have no proper systems in place with which to list reported bugs then fix them. They just simply pick a few to debug each release. This is why Steinberg have such a bad reputation…