[BUG?] Mixer window eats key commands?

Not sure I understand this. I have a key command ("/") mapped to “Disable monitor” so I can easily turn input monitoring on and off. Works fine when the Project window is frontmost. Doesn’t work when the Mixer is frontmost UNLESS the Mixer is set to “Always on Top”.

Why?

Jason

If a window isn’t always on top then it captures the key commands. Setting it to AOT allows key commands to “pass through” to the main active window behind it. Intentional behaviour so not a bug. I have all my mixer windows set to AOT.

OK, I’ll buy that. But what is the Mixer window doing with my key command when it’s not AOT and it captures the “/”? It has input monitor controls and selected tracks. Shouldn’t it respect that command whether it’s AOT or not? I guess I still don’t understand what the intended purpose is of this intentional behavior. What does it buy you?

I think, too, that you should be able to make key commands global. I don’t want to have to think about what’s on top or not when I want to enable or disable monitoring. It should just happen, right?

Jason

i can’t repro that on mac.