[BUG] Moving cut point doesn't reflect Snap to Zero Crossing

Hello, all,

when you move a cut point between two audio events in the project window in Cubase 6.0.1, the cut point is always moved regardless of whether the “Snap to Zero Crossing” button is activated or not. Since the zero crossings are taken into account when you cut the events I think they should also be taken into account when you move the cut point. Therefore, I suppose this is not intended behaviour.

Thanks for the confirmation!

Miloslav

Miloslav, can you give stepwise instructions to repro this? I’d be happy to help.

Hello, Steve,

thanks a lot for your interest! :wink: It’s quite simple:

  1. Open a new project.
  2. Activate the “Snap to Zero Crossing” button and deactivate the general “Snap” button.
  3. Import an audio file to an audio track.
  4. Split the audio event in the project window with the Scissors Tool. (The event will be split at a zero crossing point into two audio events.)
  5. Stay in the project window but zoom in so that you can see the waveform.
  6. Switch to the Object Selection Tool, point the mouse cursor between those adjacent events (vertically in the middle of them - it means not in a lower corner as this would move the start/end of a given event).
  7. Right click and move the split point.
    => You will be able to place the split point wherever you want, in spite of the fact that the “Snap to Zero Crossing” button is active.

I suppose this is a bug. Moving a split point should respect the zero crossings when this function is activated.

Remark: Moving split points wasn’t possible in earlier versions, this is a new feature in Cubase 6.

Thank you once again!

Miloslav

Two things - I don’t understand what you mean by moving the split-point (which you say is different in v6); can you elaborate please…?

Secondly, if you mean moving the end/start of the events you created when you split the one into two, then read on…

Is the general ‘Snap’ function enabled…?

Not at my machine right now, but the ‘Snap to Zero Crossing’ function is directed at the initial cut or split made - trying to move that point after the fact, is tied to the snap setting, isn’t it…? If you have S to ZC enabled too, that should give you what you expect (I hope…!). If Snap is disabled, then you’re in free-form movement mode…

(As ever, I could be entirely wrong about this). :wink:

In the previous versions, you just weren’t able to move the split (or cut) point. You had to glue the audio events back together and cut them again on a different place. But in C6, when you split an audio event into two pieces, you create a moveable split point. It was apparently introduced as a part of the new comping functionality, however, it works even without using lanes.

No, those are two different things. You can move the end/start of the events if you position the mouse pointer in the lower corner of the events, whereas to move the split point you should position the mouse pointer over the cut, but vertically in the middle of the events. Please, look at the manual page 77 (Comping with the Object Selection Tool).

No, for my application, I don’t want to activate the general Snap function. I want to be in a ‘quasi’ free-form movement mode but I want to constrain my movement to the zero crossings in order to avoid clicking cuts as much as possible. But thanks for this relevant comment, I have edited my reproduction steps regarding the general Snap function.

If I wanted to be in a completely free-form movement mode then I would disable “S to ZC”. On the other hand, keeping “S to ZC” active should indicate that I want to move the split point to a different zero-crossing. That’s my common understanding of it…

No, this was actually very helpful reply, thanks for it! :wink:

Best regards

Miloslav

Confirmed here.

After splitting the part in two, I zoomed in and placed the cursor right over the split. Cursor changes to <||> (sort of, could not get a screen shot of the cursor.)

Then held mouse button down to drag the split point (this ability is new to Cubase 6).

It does seem like the cursor should snap to zero crossings now, because why would I want to create a split at a point that is not at a zero crossing? (If there is a reason, one could turn off snap to zero crossing for that instance)

Yes, looks like a bug, or partially implemented feature…

Hello, Steinberg,

I just would like to attract your attention to this bug (or unfinished feature). There are reproducing steps in this thread.

Thank you for your response!

Miloslav

Hello, Steinberg,

I’m sorry to report that this issue has not been fixed in 6.0.3 :frowning: Could you, please, add it into the bug list, at least?

Best regards

Miloslav

Cool, didn’t even know you could move the split point, nice find! Hopefully the issue gets sorted to go along with this new feature however.