Bug: Multioutput instruments output routing is not working

  1. Create a instrument track.
  2. Enable multioutput. (I use Toontrack Superior Drummer 3)
  3. Make sure that there is output from the instruments on all outputs.
  4. Create a group track.
  5. Move the instrument to the group track.
  6. Let the instrument generate output.
    Only the first “mother” instrument are routed to the bus. The sub instruments show the group name but the output is sent do Stereo Out.

It should at least show the right output bus and it would be good if the instrument could be sent to different groups.

This is seen on 13.0.20 (intel/osx)

1 Like

Hi @cubace.

Not sure about OSX and CB13 but this is how I use SD3 in CB12 Windows.

  1. Create the SD3 Instrument Track and select your Kit of choice.

  2. Press F11 to bring up the Instrument Track Panel.

  3. Select SD3 and activate all needed outputs.

  4. Select the SD3 Instrument Track and expand it to reveal the Multi-Outs

  5. Bring up the SD3 Instrument and route the instruments to the desired outputs.

  6. Create group tracks as required.

  7. Highlight the SD3 track and bring up the channel window with that (e) from the Inspector (leave this window open)

  8. Select the SD3 Instrument you wish to route (the SD3 channel window will switch to the instrument track you have chosen. From there you can route the instrument to any of the Group Tracks that have been created, using the drop down menu from the output of the selected instrument.

Apologies for the terminology.

This is just from memory mind you, not at the PC right now.

Hope this helps.

The issue is not how to do it. The issue is that it is not working. The issue is that audio is routed to a different group-bus than displayed.

OK, sorry for the wrong interpretation.

Hopefully someone can check this with CB13 on their system. There’s enough Cubase users of SD3 around here. Sounds like a bug.

Can you replicate it in a new project?

I don’t know that a group track is required with Cubase 13. You should see track/rack instruments exposed as inputs for audio tracks. It’s not 100% clear, but the EZDrummer 3 01 is the first stereo track. I’m sure that SD3 is similar.

You can create 16 audio tracks for each of the outputs and then route them in Cubase. There’s one more step that is required though. You have to go into SD3 and route the outputs. EZD3 didn’t route them automatically for me.

Here’s what it looked like before routing in EZD3:

And after:

Hopefully, I understood what you were trying to accomplish. I’m happy to try something else if this isn’t exactly right.

Does it help with a video?

From recollection, you can not route SD3 this way (from the inspector).

The points 7&8 I made previously is what you should try.

Obviously you can. I just did it in the video. You can also verify that is partly works by adding an additional group bus and switch. It works fine for single outputs. But not for the multi outputs The GUI is showing one thing, the audio routing do something else.

On my part, I couldn’t get it to route the same way as Groove Agent doing what you showed in the video

Incidentally, have you tried Groove Agent or any other mult-out vst to see if the method you use works as intended?

It is not a bug related to the plugin. It is the same problem with NI Battery4.

I have now tested with GA-SE and it have the same problem.

O.K, so I downloaded CBAi 13 to my sketch DAW PC along with GASe.

It turns out that GASe and routing to Group Channels is the SAME way as I route SD3. I had no problem sending just the snare, for instance, to the group channel I created or any other Group Channel.

Routing the way you showed in your video, heeds a different result.

You “need” to follow steps 7&8. And use this practice for Battery, GA, and SD3.

Have you even tried the method I have suggested?

Yes. (And tnx!) It is a workaround that shows that cubase can do it. However it also shows a other bug. When routing is changed in channel settings the arranger windows does not get updated. I think we can conclude that the bug is in the arranger window. Do you agree?

1 Like

Totally agree to the fullest. It has been like this from I first started using CB from V8.

I think I mentioned this somewhere in the Forum, but not too sure. I’ve just lived with it ever since and it initially had me stumped. Took me months to figure this out.

The arranger window not updating is, as you say a bug that I just ignore.

Real glad you got it going.

All the best.

1 Like

It seems like 13.0.30 breaks the workaround. :frowning:

Can you select the group out (routing) in the mixer and does that work?

Yes, you can change the routing. But it change for all outputs. On 13.0.20 there was workaround that you can on the channel strip select DIFFERENT outputs per channel. Now ALL channels are changed on both mixer and channel thus make it impossible to have different outputs buses on a multiinstrument. :person_facepalming:

I see what you mean in the Inspector but for me it works in the mixer.

Right you are. So inspector and channel strip is broken. You can not do it there and they show incorrect routing information. The first mixer view have a other view routing and that view seems to be reflect the real audio path as well.

1 Like

I guess I never notice this before because I always do my routing in the mixer. Definitely a bug…