Bug: Mute Automation issues (multiple)

Issue: When using Mute automation, I’ve observed several issues:.

  1. Mute automation gets stuck in write mode and recorded automation does not work on playback unless you disable the channel and re-enable it. This happens consistently every time mute automation is recorded in every scenario.

  2. When you solo a different channel in a section of the song where the Instrument Track has Mute:Off - soloing any other channel will also trigger the Instrument track to solo. When solo is turned off on the other track, the Instrument track remains solo’d. This is very difficult to deal with on larger projects.

  3. When you use two audio tracks with mute automation, Solo works mostly as expected for the first track. Solo’ing the second track will still play audio from both tracks and does not observe any mute automation on the non-solo’d track (sections that have mute automation are still heard).

This is how I recreated these issues on a test project:
Open a new project
Add 1 audio track
Add 1 Instrument track (I used Komplete Kontrol)
Record some midi on the Instrument Track.
Insert a sample on the audio track
Enable write automation on the Instrument track and mute the channel after two bars, unmute after 3 bars, then disable write automation.
Enable write automation on the audio track and mute/unmute a different section on that channel, then disable write automation.
*At this point both channels showed Mute automation lane in red and the playback did not execute the mute.
*I disabled both tracks and re-enabled them to clear this error.
Solo the Audio track in a section of the song where the Instrument Track mute automation is Off.
*The Instrument track solo button will also come on and audio for both tracks is heard. Expected to only hear Audio track…
Disable the solo button on the Audio track.
*The Instrument track remains solo’d (undesirable behavior since I never wanted to solo it in the first place)
Disable solo button on the Instrument track.
Move the playback head to a position in the Instrument track where Mute=On
Solo the Audio track.
*Instrument track is muted (normal expected behavior)

Testing for two audio tracks:
Clear all solo/mutes. Remove the Instrument track, add another Audio track and add a sample to the track.
Enable write automation and turn on mute during a section of the new track, then disable write.
*mute automation stuck in write and non-functional again. Had to disable/re-enable the track.
Solo first Audio track.
*on the second audio track, neither the mute or solo button turn on, but only audio from first track is heard (as expected)
Clear solo from first track and solo the second track
*audio from both tracks is heard. First track does not observe mute automation and plays in its entirety. Expected to only hear audio from the second track.

System Details:
Cubase Pro 11.0 Build 300
Windows 10 Home Version 2004 build 19041.746
Intel i5-7600K CPU
16GB Ram
Native Instruments Komplete Kontrol S 88 mk2 firmware v0.5.9 connected via usb
Komplete Kontrol VST version 2.5.1.0

I can confirm this to still be present and it’s apparently around for quite a while:

https://forums.steinberg.net/t/automating-mute-off-also-equals-solo-when-soloing-other-tracks/122121

My only solution to this (as also suggested in the thread) is to avoid mute automation altogether and do volume=-oo instead. I even have mute automation completely turned off in the automation panel (f6), since it’s more annoying than useful to me, but that’s a personal preference.
I do all the real volume automation on pre-gain instead of volume, so I have the volume free for mixing. If you don’t use pregain, you can use that for muting tracks without messing up your fine tuned volume settings when setting it to -00 - you can go back to 0 afterwards without having to remember your volume setting.

Since it’s an old bug/behaviour I personally don’t count on it being changed in the near future. Sorry :slight_smile:

Best regards