[Bug] Number of Bars produces odd key signature

Summary: When using “Number of Bars” from the advanced Layout Menu in the Score editor in Page Mode with a staff which has a display transpose applied, the second line and following appear with an incorrect key signature until you re-load the score editor.


  1. Create a MIDI track, and enter some note data - you will need at least 8 bars’ worth (so that there are at least 2 lines in the editor). Make it in the key of C major to see the effect most clearly. Repeating the same part and then gluing it together is fine.
  2. Open the MIDI track in the score editor.
  3. Switch to Page Mode
  4. Open the Score Settings dialogue box and apply a display transpose, such as Alto Sax
  5. Go to Scores > Advanced Layout > Number of Bars, and click “All Staves” (the number of bars doesn’t seem to make any difference).

Current Behaviour: The second line onwards appears with an incorrect key signature, and many of the notes can have double sharps or needless natural signs. To correct this, the score editor needs to be closed and re-opened.
Expected Behaviour: The key signature should be correct straight away.

I know it’s not the end of the world, but it looks like a clear bug to me, and it confused me when I came across it today.

Cubase version: 6.0.1, and 6.5.0, both 32-bit. Windows 7, x64.


Come on, everyone moans that Steinberg never fixes bugs, it’s a dead simple repro, and if confirmed may get fixed. :unamused:

I’m afraid I can’t confirm that, here on Mac OS X 10.6.8.

(try the classic trashing of Cubase Preferences)

Confirmed. Behaves exactly as described by OP.
Tested with Cubase 6.5 x32 on Win7x64


Cannot confirm with C6.5.1 (tried both 32-bit and 64-bit) Windows 7 Pro 64-bit.

Started in key of C changed to key of A (using alto sax).

How are you entering the midi notes to begin with? I used the score editor. Maybe it doesn’t appear in that case.


Ron - In the tests I’ve done, the MIDI notes have been entered by two means - either played in via a MIDI keyboard, or input using the key editor; I’ve tested both ways on both 6.0.1 and 6.5.0, and both do it in the same way. I have just tried it entering the notes in the Score Editor (which was a hideously painful experience!), and it still behaves as per the repro - did you follow the steps fully?

Vic - I’ve just tried it, having trashed the preferences. Still behaves as described.

Wow, I’ve just tried it again (Cubase 6.5.1), starting from an empty Project… and I can now confirm!
But doesn’t happen from my default template. (I’ll go see if I can spot anything…)

… I have, so far, narrowed it down to something inside the Score Settings dialog (I exported my settings from the .cpr where it works o.k., and then loaded the new Project (which does have the problem), then imported my Score Settings. It then worked o.k.
Now, to explore which of those settings it could be…

… I found it (but it defies all logic!!)
Please see if this fixes it for you…
Score Settings>Project>Accidentals>Mode…
The problem seems to occur if the settings in that pane are anything other than the option, “Courtesy Acc Distance”: with a value greater than zero.
(maybe the strangest one I’ve ever seen :stuck_out_tongue:)

OK - I recreated. I misread 2 lines with 2 measures. In my case the first 3 lines were fine, but the 4th line is messed up. Haven’t tried Vic’s test yet. But yes - this is a bug.


… I’ve also just found that it gets corrected simply by using the UPD button :wink:

Hi Vic

I can confirm that the settings you mentioned (Score Settings>Project>Accidentals>Mode) do indeed stop the problem happening, and also that the UPD button fixes it (which would be the same as closing the score editor and re-opening it), but it still looks like it’s confirmed then?

I’ve also just tried it in Cubase 5.5.2 and get the same result (Win7 x64).