Bug or by design?

When I select to view the plugin from the second Send FX channel in the track header it opens the Edit Channel instead of the plugin.
Screen Shot 2019-02-14 at 9.11.45 PM.png
Please see brief video.

Hi,

I wouldn’t say this is by design. It seems to be wrong. My expectation is, the Channel Settings Window should open every time. Look at this scenario:

  • Audio, connected to Send 1
  • Send 1: Insert 1: Compressor
  • Send 1: Insert 2: EQ
  • Right-click to the Send icon of the Audio track. Only s1: FX1 appears, so I have no access to the S1: Insert 2: EQ. Doesn’t make sense. Why only the 1st plug-in should be accessible?

Btw, I cannot reproduce your scenario, but I don’t have Verb plug-in installed.

Thanks for your reply Martin.

I figured it out. It’s all in the sequence in which we initiate a send/fx channel whether it connects via the channel header buttons or not.

Please see quick video explanation:

https://youtu.be/q12GgFvaxOk


Here’s a good suggestion though:

https://youtu.be/eC13q3zlIFk

Hi,

I cannot confirm your observation. My steps:

  1. Add an Audio track.
  2. Add a FX Channel (not FX Channel to Selected track).
  3. Add Compressor to the FX Channel.
  4. Connect Send 1 of Audio track to the FX Channel.
  5. Add another FX Channel (not FX Channel to Selected track).
  6. Add Delay to the FX Channel.
  7. Connect Send 2 of Audio track to the FX Channel.
  8. Right-click to the Bypass-send of the Audio track and select FX 1
    -> Compressor plug-in appears.
  9. Right-click to the Bypass-send of the Audio track and select FX 2
    => Channel Settings window appears.

Thanks for your reply Martin.

What I was demonstrating was that there are 2 different results when adding FX channels in 2 different ways.

Please see new short demonstration video:

https://youtu.be/RVfkS_lZkNQ