Bug or feature request - not sure? overwrite file not always allowed?

When working in the montage, sometimes I’ll delete a clip (let’s say VERSION4.WAV)… and when I go to record a new clip into the montage, it tells me VERSION4.WAV is already open in Wavelab - even though I’ve deleted the clip from the montage, and it’s not open. I want to use that file name, and overwrite the clip I deleted, but it won’t allow me to overwrite VERSION4.WAV.

In order to overwrite, I have to:

  1. Delete the clip
  2. Save the montage
  3. Close the montage
  4. Open the montage again
  5. Now I can record into the montage using the file name VERSION4.WAV (it gives me the option to overwrite, and it works now).

I’d really prefer to:

  1. Delete the clip
  2. Record into montage (with prompt if I want to overwrite VERSION4.WAV)


This is because the file is still opened in the “undo history”. Only way is to use a new name.

Any chance the popup could say “The file is still open in the undo history. Would you like to clear the undo history, and overwrite the file?

I’ll never end up choosing a different name, because I have a file naming system that helps me keep organized. I’ll just keep opening and closing the entire montage…

This is not as easy as it seems, unfortunately. However, some better solution might happen in the future, as I am aware of this case.

Ok sounds good. Thanks PG.

Hey PG,

I noticed that even after I close a montage, sometimes the undo history is still not flushed. There are no files open at all. Then I load a montage, and try to record into it… Wavelab tells me the file is already open… but there should be no undo history, and the file is not open.