Bug: Project Logical Editor, "Unequal" condition not working

Try to hide everything except Folder Tracks : (attached image also)

Container Type is ___ Unequal ____ FolderTrack
Track Operation ____ Hide Track __ Enable

This hides everything. When I do the opposite, i.e. Container Type is Equal FolderTrack, it hides the folder tracks only.

Am I doing something wrong?

Bump until I get a response

The workaround is simple, but it doesn’t change the fact that this is not working.


And the workaround is…?

I haven’t tried yet but since “equal” condition is working:

  1. Container Type ---- All Types

  2. Track operation ---- Hide track ---- Enable

  3. Container Type ---- FolderTrack

  4. Track operation ---- Hide track ---- Disable

First hide all tracks, then show folder tracks only.

I’m not sure if it will work though. If Folder Tracks was an option in “Filter Track Types” dropdown menu, it would be nice.


I just tested this (with Unequal option) on my side with Cubase The result is, all tracks are hidden. Only an empty folder stays visible.

The reason is Cubase is scanning the tracks one by one from top to the bottom. And if you hide all tracks in the folder, the folder becomes hidden two. These facts together comes to the result we observe.

Imagine you have Audio01 and Audio02 in the Folder. So Cubase is testing:

  • Folder: Don’t hide.
  • Audio01: Hide.
  • Audio02: Hide.
    => All tracks in the folder are hidden, hide the Folder.