Bug? Removing piano staff on multi-inst. part

I’ve created a score with single player who plays piano and bass clarinet.
Most of the beginning of the music is only played with the left hand of the piano so I wanted to remove the top stave to save some space.
When I do this, the stave indeed disappears, but then the bass clarinet stave appears, even though it contains no music.
I even tried selecting the bass clarinet stave and choosing “remove stave” but then it just disappears forever!

There is an option to allow individual staves of multi staff instruments to be hidden automatically when Hide empty staves is activated in Layout Options. I think it’s somewhere in Engraving Options… sorry, I’m not sure because I’m not in front of Dorico now. If you do it this way you won’t need to remove staves manually.

I think you would be better off using Remove Staff on the right-hand staff of the piano and manually hiding and showing that staff, rather than using the ‘Hide individual staves of grand staff instruments’ option in Layout Options. Out of interest, can you play the bass clarinet one-handed?!

This is actually the way I did it - i.e. using Remove Staff on the top stave.
I just tried it on an new empty score:

  • created one player playing piano and bass clarinet.
  • wrote some music on the bottom piano staff
  • selected Remove Staff on the top piano staff
  • hey presto - the (empty) bass clarinet part appears!

and yes! I position the bass clarinet between my legs, resting on the floor and use one hand for fingering. Of course not all the instrument range is available, so the simultaneous b.c.+pno parts have to take this into account.

Oh, and sorry for the inconsistent use of “Staff” and “Stave”.