BUG REPORT - "Bypass Master Section" button not working sometimes

I’ve noticed that sometimes the “bypass master section” switch does not work.

  1. Load a relatively quiet audio file into montage (192khz in this case).
  2. Load gclip vst plugin with a major boost (maybe 12db in this case) into master section
  3. Render to 192khz file (do not use any sample rate conversion, etc
  4. A new window opens with the exported file, and the “bypass master section” switch has been automatically activated (the button is now red, and the gclip plugin has been greyed out).
  5. Hit play, and you will hear the exported file with the 12db boost, BUT, it is now an additional 12db louder!!! Although the “bypass master section” switch is enabled (Red), AND gclip is greyed out, PROCESSING IS STILL OCCURING WITH GCLIP (so it’s boosting another 12db in addition to the original boost from the export).

How to fix?

  1. Click the “bypass master section switch” - so the button is now green and the gclip plugin is no longer greyed out.
  2. Hold CTRL while clicking the gclip plugin in the master section, and it will be greyed out again… this time, it is actually bypassed.

Toader, is it the same as this?

https://www.steinberg.net/forums/viewtopic.php?t=128280

Are you hearing it 24db louder than the original unprocessed file (rather than 12db louder), or just seeing it 24db louder on the Master Section meters? If I understand correctly you should just see it 24db louder, not hear it that way. That’s what I get here anyway with the Steinberg Gain plugin. I only hear the +12 gain that the render file is. But the Master Section meters show +24, and the Wavelab Level meter shows +12. It’s confusing to me, but I guess that’s the way it has to be now (?)

I believe it’s a different issue than the one you mention above.

As far as 24db vs 12db, I was both seeing, and hearing the playback at 24db louder (but the underlying file was only rendered 12db louder (and the WAV image looks correct - but the plugin is still adding an additional 12db because it’s active when it shouldn’t be). The plugin was greyed out, the master section bypass button was red, but the plugin was still processing audio. In order to DISABLE the plugin processing, I could 1) Re-enable the master section (so the button is now green), and the plugin is no longer greyed out. 2) Then bypass the plugin, or hold CTRL+click the plugin to full power it off. If I clicked to bypass the master section again though (button is red again), processing was still occurring when it should not be occurring.

This problem does not ALWAYS happen, but unfortunately, it has happened to me MANY times. I seem to notice it occurring usually immediately after exporting a file (when the resulting file after rendering is automatically opened in a new window).

I can’t reproduce the problem using the gclip plugin.
But note:

  • bypassing the Master Section means: the plugins are still fed with audio, but the output is discarded. That is, the plugin shows some activity (but you don’t hear it). This method is used to have smooth transition between bypass on/off.

  • Control + click on a Master Section slot, means deactivating the plugin. The plugin is not inserted in the audio chain.

Here is a video showing the problem:

https://youtu.be/rSUHUDoeY1s

So far, , I have not had this problem with any plugins. What I have noticed on occasion is that the bypass does not bypass after rendering but I can manually change from bypassed to process. If this is a glitch it is not a “good” glitch. Do you get this will all plugins or only the one you mentioned?

Yes, it always seems to occur right after rendering - Wavelab automatically opens the rendered file, and bypasses the master section, but it is not truly bypassed. It doesn’t seem to matter what sample rate I’m working at or anything either – in the video, it was happening at 44khz.

This problem occurs very often - it has happened many many times… so it’s not just an occasional glitch.

In the video, obviously it shows the issue with Ozone, but I have had the issue with other plug-ins also - gclip being one of them. Yes, this is definitely concerning…

There must be a special sequence of events to reach that case.
So far I could not reproduce, hence if you have more ideas…
I have to reproduce this. If I can, it will be fixed in next patch.

There is nothing special I can think of… but here was my workflow last night:

  1. I use two computers, so computer #1 is doing playback (Cubase), and computer #2 (with Wavelab) was monitoring through the audio input plugin while working. The only plugins running on the Wavelab side were the Wavelab included mbit+ dithering plugin, and the Ozone Maximizer as shown in the video.
  2. When happy with the sound, before recording into Wavelab, I remove the audio input plugin.
  3. I then CTRL+click Ozone Maximizer and also the mbit+ dithering plugin to bypass them both (so no plugins are active).
  4. I then click the record button in Wavelab to open the record dialog, and I begin recording.
  5. I then click play in Cubase on computer #1.
  6. When recording is done, I stop recording, and the newly recorded file has been added to the montage.
  7. I adjust the fade-in and fade-out for the new clip in the montage.
  8. I then CTRL+click Ozone Maximizer and the mbit+ dither plugin to re-enable them.
  9. Click render to render the Ozone Maximizer and mbit+ Dither plugins.

At this point, the plugins are rendered. A new window opens with the rendered file in it, and the master section is automatically bypassed (but bypass is not truly working).

There is nothing special happening here. The only thing I can think of that I also do occasionally, is instead of using the Wavelab “input plugin” (because it adds a lot of latency), sometimes while working I’ll use the RME mixer and just use direct monitoring (not monitoring through Wavelab). When working this way, I have no latency, but cannot monitor through real-time effects within Wavelab. While working this way, I click “monitor input” in Wavelab to enable the Wavelab meters though - so I can see the peak and RMS levels within Wavelab.

This problem occurs OFTEN. It’s not occasional - it has come up many times in the past. You can see this thread was originally posted in June, but it began long before that.

Also, I don’t know if it helps, but I think I was monitoring with the RME mixer rather than Wavelab while recording the file into the montage.

Toader, I’ve been able to reproduce your problem twice, but I’m not sure what the exact sequence of events is. I noticed your Ozone plugin was in slot 2 and remembered you used the Audio Input plugin, so I assume you removed the Audio Input plugin recently. So I tried the same thing, inserting the Audio Input plugin in Slot 1, the built-in Voxengo Curve EQ in Slot 2 with it’s output level down 12 db, and then played around for awhile with bypassing and un-bypassing the Master Section while using the Audio Input plugin. Then I removed the Audio Input plugin, started normal play of a file, and tried bypassing the Master Section like you did, and I got the same thing you did: Bypassing had no effect even though the output level of the Voxengo should have made a big difference.

Before I tried doing this with the Audio Input plugin, I couldn’t reproduce your problem at all, and still can’t unless I do this thing with the Audio Input plugin first.

btw it might take a few tries for somebody trying to reproduce this. Like I said, I don’t know the exact sequence of events. The first time I tried the Input Plugin thing, I got the problem. The second time, I didn’t. The third time I got the problem again. So it might take a few tries to reproduce this. I just don’t know exactly what you need to do while the Audio Input plugin is in to make it happen after the Audio Input plugin is removed.

I will try it today and see if I get the same thing. Mostly when I get the non bypassed problem I am using Fab Filter plugins AND it is not always a problem. Seems to be “random”.

I don’t think this can be related to a specific plugin. But the (special) Audio Input plugin was mentioned in all cases, apparently.

I’ll try to narrow it down more somehow too… although it feels pretty random here as well. Maybe it is tied to the audio input plugin… hopefully that will point us in the right direction. Thanks guys for checking it out!

I can’t make it Not fail now, so maybe my 2nd trial I did something wrong. You don’t even need to set up audio connections for the Audio Input plugin, or do anything while the Audio Input plugin is inserted to make it fail.

This creates the problem for me every time now:

  1. Insert the Audio Input plugin in Slot 1.
  2. Insert the built-in Voxengo EQ in Slot 2. Turn the Voxengo output down to -12.
  3. Remove the Audio Input plugin.
  4. Open an audio file and play.
  5. Toggle Bypass in the Master Section. There is no difference in level, when there should be a 12 db difference in level from the Voxengo. So the Master Section bypass is not bypassing the eq plugin.

This only happens inserting and removing the Audio Input plugin, not the External Gear plugin.

@bob99
Congratulations! I can reproduce too now. I will analyse the problem from inside now (well, in the next days).

Awesome news - thanks guys!

Found and fixed (targeted for 9.5.40)