Bug report: Cubase Pro 11 hangs on Undo 'Delete empty tracks' preset

Cubase v. 11.0.41 build 448 on MacOS Monterey 12.0.1
report for Steinberg team
Symptoms and steps to reproduce:

Consider you have big (orchestra) template where some tracks are empty.

1. Go to Project → Apply Project Logical Editor Preset → Tracks → Delete empty Tracks.
2. UNDO this operation
3. Cubase hangs


Does it hang forever or does it recover after some time, please?

Hi Martin!

With my current setup and current project – yes, forever. (forever starts from 5 minutes for me).

Addition: I created my own preset which deletes all empty MIDI tracks. It applied correctly. Then I tried to reproduce the issue – I executed predefined preset ‘Delete empty tracks’, and undo it – it worked as expected.

I think my steps to reproduce the issue is not enough to raise an issue. So I will continue to investigate this, and will try to provide you more valuable info to help. But the issue happens at some point when you have big template with instruments + MIDI + group + fx tracks.

Note: I think this preset is a bit deluding. E.g. I can have a group track with plugins in it to process inputs. But it is empty (without events), and it is deleted with the preset. So, I would suggest to prevent deleting group/fx tracks with this preset, if they have inserts.

Thank you for paying attention to my case. I will let you know when I build reliable steps to reproduce.


Do I understand you right, it hangs after using your own Logical Editor preset and then Undo? It doesn’t hang with the factory preset?

Could you share your custom Logical Editor Preset, please?


No, not exactly. It hanged after using factory preset Delete empty tracks and then Undo. I did force quit Cubase and tried again 3 times, and Cubase hanged all these tries.

But when I applied my own preset for deleting empty MIDI tracks only first, I was able to execute factory preset Delete empty tracks + Undo after this with no issues.

So as soon as there is no problem with my custom preset, you don’t need one, I suppose?



I see. Thank you for clarification.

What is different in your custom preset in comparison to the factory one, please?

The factory preset deletes all empty tracks (all types). My preset deletes only MIDI tracks (no group/fx/audio tracks). Because as a composer I want to clean up empty tracks to decrease the scope, but want to leave intact my group + fx tracks where I am sending and process data from instrument tracks.


Then it will by interesting to know, which track type causes the issue.

I just created a new project with my orchestra template.
If I use factory preset Delete empty tracks and Undo it from the top menu – it works. If I do Undo with hotkey Cmd+Z – it hangs.

I created empty project with my template and checked these steps for several times, and behaviour is the same: it works from the menu (Undo), but hangs with Cmd+Z. So I bet there are different functionality.

I filmed the video to illustrate the problem: 1) I create new project and Undo works from the menu. 2) I create project and Cmd+Z hangs Cubase:

Cubase have problem with hang on exit (there are vast thread on the forum) while unloading certain plugin (or combination of plugins) it gets stuck in the memory. I mentioned this since i experience similar thing (on windows though) with xfer ott plugin which makes cubase to hang on exit all the time, but once in a while it get stuck when unloading/undoing(but not every time)

Try trouble shooting by disabling 3rd party plugins going vendor by vendor. So for ex: disable all fab filter plugins and try to trigger the issue, if stuck continue with other vendor to the point where you cannot replicate it. Apologize if i miss some detail from above.