Bug report: multi-measure rests inconsistent

Forgive me if someone else posted this and I missed it. I recently exported an arrangement for my parish, and found several weird inconsistencies with multi-bar rests, as shown below:
PTLWard-Hnrests.png
While it provided a few laughs in rehearsal, I’m sure levity is not the goal here. Thanks!

I had the same problem. It turns out that Dorico generates hidden time signatures for some reason. The workaround is to delete the hidden signatures and then the bar(s) will be incorporated into the multi-bar rest.

Thank you. Firstly:
image.png
Secondly: for those of you needing to fix this, you’ll need to select each barline and uncheck “Hide time signatures” as seen in the properties panel below.

This will be much easier to resolve in 1.0.10, as bar divisions that hide time signatures will show signposts, allowing you to delete them or otherwise decide what to do about them much more easily and with no guesswork.

I seem to have many problems still with the multi-measure rests. Often if I have a string of, say, 8 completely empty measures, the layout will have a single measure at the end of one system and a multi-measure of 7 bars on the next system. I can get around that by forcing a system break before the first measure, then it displays properly. That is very common, so I am surprised this bug is still in the product.
A problem I cannot get around is the behavior that evidently attaching any text to the first measure in the flow causes that measure to be separated from the following measures. Tempo markings, rehearsal marks and other things do not cause this problem. Only text items. See the examples below. Can anybody give me a solution?

Also notice on the “correct” example, the same problem happens to the flow above (Berceuse). If I don’t add that text, that flow appears as a single multi-measure strip the width of the page, labeled “Tacet”, which is far preferable to this treatment.

Correct (more or less):
https://imgur.com/a/QnVXhVL

Broken:
https://imgur.com/a/B1lMZrc

The solution is to use global text (shift+alt+x) instead of local text (shift+x). That solves both problems perfectly.

Actually, the “official” solution is to use text frames for flow titles, taking advantage of the {@flowTitle@} wildcards. The developers haven’t really given us an easy way of doing that when the option to allow multiple flows on a page has been selected, but they’ve promised that in future it’ll be possible to automatically put the “front matter” (title, composer etc.) above each flow on a page rather than just the first flow present.

In other words that isn’t a solution if you need to put flows back to back on a page, with the idea that parts for different players will all flow correctly without having to do special layouts for each player.

The global text works adequately. I’d hope for a more elegant solution in the future.

Sure, but I can’t see how inputting “Berceuse - tacet” as global text is adequate, because presumably somebody else is playing the Berceuse and you won’t want “tacet” showing in their part.

Am I missing something?

Good point. I added Tacet to the text at the point that the empty flows were displaying as two empty measures. But by using the global text, I was able to get the empty flow to show as a single system with a mm rest symbol and the word “tacet” appearing above the rest symbol. So the text “Tacet” is redundant. I believe with this solution, if my global text said “Berceuse”, that would work for all players. In this case, I have only the one player, so I can’t say for sure, but it looks like it should work.