BUG: Respell accidental not working

Respell accidental does not work properly in Dorico 3.5. Only works for going up one note, not down. Disappointing and breaks workflow… Using Portuguese keyboard…

I believe the problem here is that there is a collision between the Respell Using Note Below command and the new “instant print preview” command. You should be able to fix this for yourself by changing the shortcut for Hide Invisibles in the Key Commands page of Preferences. So far as I know this is already fixed in our development builds ahead of the next update.

Thanks for the reply, Daniel. Actually, instant print preview / hide invisible works with ‘§’ on the Portuguese keyboard (the key to the left of number 1). There is no collision on the Key Commands in Preferences… so can’t really use the respell accidental with note name below as it is supposed to. Only way is to define another shortcut which is cumbersome… I loose the fluency I’ve been acquiring!

Respell accidental was not fixed… Can’t use option-’ to respell

Anda can’t define it properly in the key commands dialog… This causes major slowdown in editing…

What happens when you try to define it to another key? E.g. nothing by default is bound to the single-key shortcut J. If you bind it to that key, does it work as expected?

Daniel,

In key commands I try to find define option-’ and it accepts it. Then, when I close preferences, the key command does not work. When I go back to preferences, nothing is shown in the Respell Accidental with the Note Below.

Note that Fast Print Preview in the Portuguese keyboard is shift-’, which equals: ?

Sibelius also used to have problems with the Portuguese keyboard… I can well remember those issues!

When I define J as the key for respell accidental, it doesn’t work.

Can you please zip up and attach your keycommands_pt.json file from your user application data folder, so I can get a look at it?

Dear Dorico team. This is still unsorted with the Portuguese keyboard… causing distress and slow productivity.

Did you ever pass on your keycommands JSON. If not, could you do so now, please?

keycommands_pt.json.zip (356 Bytes)

Sorry, here it is!

@dspreadbury can you please have a look at this? thank you

When I get a chance, yes, but I can’t promise it will be right away.

Thanks so much in advance, Daniel.

Dear Steinberg,

This is taking a lot of time to sort out. I’m sorry to say but this is really beginning to look as bad costumer support. It’s a basic functionality that does not work with a Portuguese keyboard. I’m a costumer, have invested in Dorico and reasonably expect basic bugs to be ironed out, especially since this functionality did work well in previous versions.

I’m sorry if you’re dissatisfied with my ability to help you. We are all working from our homes at the moment, as we have been since March last year, and all of our keyboards etc. that we use in our localisation work are in our office in London. We are being advised by the UK government to avoid travelling unless it is absolutely necessary, and to work at home if it is possible to do so. When it is possible for me to check this with a Portuguese keyboard, I will do so, but I’m afraid I can’t say when this will be. I’m sorry for the inconvenience caused.

1 Like

Can you tell me again exactly what happens when you try to define your own shortcuts in the Key Commands page of Preferences? The JSON file you uploaded shows only a single custom shortcut, overriding the shortcut for the “instant print preview” feature to use the section mark (§).