(bug) Rotary effect uses the wrong default settings internally

This affects even the oldest version of Cubase I still have installed (7.5), but the bug is probably older than that.

  1. Create a stereo audio track
  2. Use “TestGenerator” as an insert effect. The default settings are fine.
  3. Use “Rotary” as an insert effect.
  4. Click the middle of all knobs except “Speed Mod”. Be careful to NOT change the values.
    -> Result: Even though the values didn’t change, the sound very audibly changes when you click the knobs. This is specially noticeable when you click the “CrossOver” and Bass Slow and Bass Fast knobs.

The Rotary effect uses the same algorithm and default settings as the Cubase SX 3 version, yet it doesn’t sound the same if you compare them side by side (confirmed by another user months ago). Well, that’s why: The new VST3 version isn’t actually using the settings shown. When you click the middle of the knobs, the correct settings are used, and THEN it sounds pretty much exactly the same.